Bug 444027 - weird messages in /var/log/messages
weird messages in /var/log/messages
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
: SELinux
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 12:51 EDT by Matěj Cepl
Modified: 2008-05-06 17:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 17:15:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/audit/auditd.conf (503 bytes, text/plain)
2008-04-25 16:31 EDT, Matěj Cepl
no flags Details
/etc/audit/audit.rules (373 bytes, text/plain)
2008-04-25 16:35 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2008-04-24 12:51:24 EDT
Description of problem:

What's this?

[root@viklef log]# grep 'audit rule' messages
Apr 23 00:04:13 viklef kernel: audit rule for selinux 'dhclient_t' is invalid
Apr 23 00:04:13 viklef kernel: audit rule for selinux 'mcstransd_t' is invalid
Apr 23 00:04:13 viklef kernel: audit rule for selinux 'samba_t' is invalid
Apr 23 00:05:17 viklef kernel: audit rule for selinux 'dhclient_t' is invalid
Apr 23 00:05:17 viklef kernel: audit rule for selinux 'mcstransd_t' is invalid
Apr 23 00:05:17 viklef kernel: audit rule for selinux 'samba_t' is invalid
Apr 23 10:30:11 viklef kernel: audit rule for selinux 'dhclient_t' is invalid
Apr 23 10:30:11 viklef kernel: audit rule for selinux 'mcstransd_t' is invalid
Apr 23 10:30:11 viklef kernel: audit rule for selinux 'samba_t' is invalid
Apr 23 10:31:15 viklef kernel: audit rule for selinux 'dhclient_t' is invalid
Apr 23 10:31:15 viklef kernel: audit rule for selinux 'mcstransd_t' is invalid
Apr 23 10:31:15 viklef kernel: audit rule for selinux 'samba_t' is invalid
Apr 23 13:50:50 viklef kernel: audit rule for selinux 'dhclient_t' is invalid
Apr 23 13:50:50 viklef kernel: audit rule for selinux 'mcstransd_t' is invalid
Apr 23 13:50:50 viklef kernel: audit rule for selinux 'samba_t' is invalid
[root@viklef log]# grep mcstransd_t /var/log/audit/audit.log
[root@viklef log]# 

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.3.1-35.fc9.noarch
Comment 1 Daniel Walsh 2008-04-24 16:15:19 EDT
Are you installing some kind of audit rules?
Comment 2 Matěj Cepl 2008-04-25 03:26:16 EDT
If yes, then by mistake. How could I know?
Comment 3 Daniel Walsh 2008-04-25 06:01:22 EDT
I don't know.  

Steve any ideas?
Comment 4 Steve Grubb 2008-04-25 06:28:22 EDT
These messages seem to be coming from the kernel. It looks like a bunch of audit
by selinux type rules were loaded. These would be something like:

auditctl -a exit,always -F subj_type=mcstransd_t

They could either be loaded at the commandline or /etc/audit/audit.rules.
Anyways it looks like maybe a change to policy occurred that made the rules
invalid. So, the kernel was warning that the rules were being deleted after that
policy was loaded.
Comment 5 Matěj Cepl 2008-04-25 16:31:45 EDT
Created attachment 303820 [details]
/etc/audit/auditd.conf
Comment 6 Matěj Cepl 2008-04-25 16:35:04 EDT
Created attachment 303821 [details]
/etc/audit/audit.rules

And I swear I have never ever seen command like you mentioned in my life, even
less I would type with my hands.
Comment 7 Daniel Walsh 2008-04-25 16:44:18 EDT
Could a post install script of an rpm have caused this or a rhts test script?
Comment 8 Matěj Cepl 2008-04-26 02:33:51 EDT
(In reply to comment #7)
> Could a post install script of an rpm have caused this or a rhts test script?

The question was probably not targeted towards me, but just to note that I have
never had anything to do with RHTS, and even more it doesn't touch my personal
computer.
Comment 9 Daniel Walsh 2008-05-02 15:17:54 EDT
Are you continuing to see this on reboot?  Have you seen this again?
Comment 10 Matěj Cepl 2008-05-03 03:23:31 EDT
No error message since 2008-04-26. Thanks a lot.

Note You need to log in before you can comment on or make changes to this bug.