Bug 444056 - Satellite should allow the update from Release X to Release Y
Satellite should allow the update from Release X to Release Y
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent (Show other bugs)
Nightly
All Linux
urgent Severity high (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Og Maciel
: FutureFeature, Triaged
Depends On:
Blocks: sat-nextgen
  Show dependency treegraph
 
Reported: 2008-04-24 15:48 EDT by Issue Tracker
Modified: 2014-09-18 13:01 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:07:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2008-04-24 15:48:58 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2008-04-24 15:49:00 EDT
Feature Request on behalf of IZN Niedersachsen

Customer would like to have the possibility to schedule updates for clients within satellite which will update all packages from version A to version B. 

Example: Customer has a system with RHEL4U2 registered to satellite and wants to update all packages to the state of RHEL4U5. All through the satellite.

In RHEL 2.1...4 there is the workaround using "up2date --upgrade-to-release=<version>", followed by an "up2date -p" but that does not appear to exist in RHEL5 any more. 

Customer requests this feature as a precondition to extend his RHN contract at the end of 2008.

Maybe this RFE is superfluous if there is anything like that in the new API which is due to appear in Satellite 5.1, so please let me know either way.
This event sent from IssueTracker by jwest  [SEG - Feature Request]
 issue 168411
Comment 2 Issue Tracker 2008-04-24 15:49:01 EDT
SEG RFE Template


[Customer/TAM driven section]
What is the exact nature of the problem trying to be solved with this
request?

Customer would like to have the possibility to schedule updates for
clients within satellite which will update all packages from version A to
version B.

Example: Customer has a system with RHEL4U2 registered to satellite and
wants to update all packages to the state of RHEL4U5. All through the
satellite.

What, if any, business requirements are satisfied by this request? (What
is the use case context?)

It will facilitate the use of their satellite significantly.

List the functional requirement(s) for performing the action(s) that are
not presently possible. Please focus on describing the problem related
requirements without projecting any specific solution.

Example implementation: 

1) Customer clicks on a system S 
2) Finds an button showing "Update all packages to version" + Pull down
menu containing all available releases
3) Customer selects, confirms and action is scheduled.

Each functional requirement must have clear acceptance criteria so Red Hat
understands what success looks like. If test cases can be provided this
would be even more ideal (bonus points for RHTS test cases).

see above.

What is the desired release vehicle to satisfy these requirements? Major
release Minor release

Satellite 5.2+

Please justify with reference to the release vehicle policy described in
the RHEL Inclusion Criteria wiki page

What package(s) are affected by this RFE? (List "new" if new technology
is likely to be required)

RHN Satellite 5.x

[Red Hat Sales driven]
Who is the sales sponsor?

What is the Red Hat business oportunity with this customer?

IZN Niedersachsen is a IT Provider for government departments like police
force, ministerial offices etc. Altohugh IZN itself does not have that
many subscriptions, they create high visibility in their market. They are
a strategic customer who frequently is visited by GPS and presales.

What is the status and risk to the contract if this RFE is not satisfied?

We stand to loose them as a customer by the end of 2008. 

[Red Hat Engineering]
What is the scope of this request for work required and risk?

What technology (specific list of packages) is affected by this RFE if not
fully captured above?


This event sent from IssueTracker by jwest  [SEG - Feature Request]
 issue 168411
Comment 3 Jeremy West 2008-04-24 15:49:55 EDT
I swear I've seen another existing BZ asking for this same thing, however I
can't seem to find it now.  My apologies if this is a dup.
Comment 11 Jason Willeford 2011-05-09 13:28:51 EDT
Poking this bug again.  Customer asked about the status again.  I also increased the severity, not sure how this request has gone on for so long without more attention due to the amount of customer interest.

Also, going to a specific U release in most cases won't do any good.  Given the fact that we have had numerous 0-day fixes, depending on the severity, a 0-day can easily nullify a point release.
Comment 102 Mike McCune 2013-07-18 11:09:14 EDT
TESTPLAN:

 * Register a RHEL 6.3 client, ensure release version is set to 6.3
 * Update release version to 6.4
 * Schedule a package update for "*" (all packages)
 * Ensure the system is upgraded to 6.4
Comment 104 Justin Sherrill 2013-10-22 15:26:54 EDT
small bug prevented this from happening:

https://github.com/Katello/katello/pull/3248
Comment 105 Og Maciel 2013-10-22 15:27:54 EDT
The entire process for verifying this BZ is almost 100% complete. Sadly, clicking the Update Button in the UI fails with:


[ERROR 2013-10-22 15:26:25 app b200231870f4bf53ca0511c655403445 #2659] *** ERROR: Packages must be provided (400) ***
[ERROR 2013-10-22 15:26:25 app b200231870f4bf53ca0511c655403445 #2659] REQUEST URL: /katello/api/systems/1a9bc274-71ad-47d3-81d6-882f9b41b588/packages/upgrade_all
[ERROR 2013-10-22 15:26:25 app b200231870f4bf53ca0511c655403445 #2659] HttpErrors::BadRequest: Packages must be provided

Environment:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-18.el6sat.noarch
* foreman-compute-1.3.0-18.el6sat.noarch
* foreman-libvirt-1.3.0-18.el6sat.noarch
* foreman-postgresql-1.3.0-18.el6sat.noarch
* foreman-proxy-1.3.0-3.el6sat.noarch
* katello-1.4.6-39.el6sat.noarch
* katello-all-1.4.6-39.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-24.el6sat.noarch
* katello-cli-common-1.4.3-24.el6sat.noarch
* katello-common-1.4.6-39.el6sat.noarch
* katello-configure-1.4.7-5.el6sat.noarch
* katello-configure-foreman-1.4.7-5.el6sat.noarch
* katello-configure-foreman-proxy-1.4.7-5.el6sat.noarch
* katello-foreman-all-1.4.6-39.el6sat.noarch
* katello-glue-candlepin-1.4.6-39.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-39.el6sat.noarch
* katello-glue-pulp-1.4.6-39.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
* pulp-server-2.3.0-0.22.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.7-1.el6sat.noarch
* signo-0.0.22-2.el6sat.noarch
* signo-katello-0.0.22-2.el6sat.noarch
Comment 108 Og Maciel 2013-10-24 18:29:22 EDT
Verified:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-20.el6sat.noarch
* foreman-compute-1.3.0-20.el6sat.noarch
* foreman-libvirt-1.3.0-20.el6sat.noarch
* foreman-postgresql-1.3.0-20.el6sat.noarch
* foreman-proxy-1.3.0-3.el6sat.noarch
* katello-1.4.6-47.el6sat.noarch
* katello-all-1.4.6-47.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-27.el6sat.noarch
* katello-cli-common-1.4.3-27.el6sat.noarch
* katello-common-1.4.6-47.el6sat.noarch
* katello-configure-1.4.7-7.el6sat.noarch
* katello-configure-foreman-1.4.7-7.el6sat.noarch
* katello-foreman-all-1.4.6-47.el6sat.noarch
* katello-glue-candlepin-1.4.6-47.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-47.el6sat.noarch
* katello-glue-pulp-1.4.6-47.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
* pulp-server-2.3.0-0.22.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.7-1.el6sat.noarch
* signo-0.0.23-2.el6sat.noarch
* signo-katello-0.0.23-2.el6sat.noarch
Comment 111 Bryan Kearney 2014-04-24 13:07:27 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.