Bug 444063 - distorted images.
distorted images.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 16:36 EDT by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-25 02:30:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
distorted image #1 from http://l.yimg.com/www.flickr.com/images/en-us/video/video_group_promo.png (13.40 KB, image/jpeg)
2008-04-24 16:36 EDT, Dave Jones
no flags Details
distorted image #2 from http://l.yimg.com/www.flickr.com/images/flickr_logo_gamma.gif.v35314.14 (4.47 KB, image/jpeg)
2008-04-24 16:36 EDT, Dave Jones
no flags Details

  None (edit)
Description Dave Jones 2008-04-24 16:36:00 EDT
ff3 seems to be scaling or otherwise doing some manipulation to various images
(but not all) before displaying them, and distorting them quite horribly in the
process. Several examples from flickr.com attached.  (Though the problem isn't
unique to this site, this was the one that made me break down and file a bug).
Comment 1 Dave Jones 2008-04-24 16:36:00 EDT
Created attachment 303684 [details]
distorted image #1 from http://l.yimg.com/www.flickr.com/images/en-us/video/video_group_promo.png
Comment 2 Dave Jones 2008-04-24 16:36:44 EDT
Created attachment 303685 [details]
distorted image #2 from http://l.yimg.com/www.flickr.com/images/flickr_logo_gamma.gif.v35314.14
Comment 3 Dave Jones 2008-04-24 16:38:32 EDT
The strange thing is, if I click 'view image' after right mousing over the
corrupt images, firefox displays them perfectly.
Comment 4 Matěj Cepl 2008-04-25 02:30:02 EDT
View/Zoom/Reset
and
View/Zoom/Zoom Text Only

If it doesn't help you, please reopen.

Explanation: Firefox now includes functionality roughly equivalent (or subset
of) previously provided by the NoSquit extenstion
(https://addons.mozilla.org/en-US/firefox/addon/2592) -- i.e., it remembers per
domain the level of zoom you used, in hope that you won't you have to zoom in
again and again. NoSquint was one of the most favored extensions for Firefox by
many of its users. Apparently default is to zoom images as well as text, which
FF doesn't do as well as it could.

Conclusion is that I don't see a bug here. If you want to argue with the
View/Zoom/Zoom Text Only being unchecked by default, then probably take your
case upstream. We suck in representing our users upstream in RFEs.
Comment 5 Dave Jones 2008-04-25 03:56:30 EDT
seriously, as a default, this sucks.

So much so, I'm having difficulty holding back just how much.
I can't believe this is even remotely a viable default.
Comment 6 Matěj Cepl 2008-04-25 16:40:02 EDT
Although I totally agree that it is probably a bad default (and I have
immediately switch it on) I am afraid I could (after all I used to be a lawyer
;-)) generate legitimate reasons why it was done so. Like for people who are
HEAVILY zooming in (e.g., because their eyesight is bad) the page could be
severely distorted. Also people could object to the fact that "I wanted my page
to zoom in, so I want WHOLE page to zoom in; don't be Microsoft deciding against
my will, what's the best for me!"

And besides, you underestimate a sad fact that just by being prefering HTML
pages full of text to images (which I suspect you do ;-)), you are putting
yourself into a tiny minority of fully literate people.

Note You need to log in before you can comment on or make changes to this bug.