Bug 444090 - gnome-display-properties crashed with SIGSEGV in _start() [when running xgl]
gnome-display-properties crashed with SIGSEGV in _start() [when running xgl]
Status: CLOSED DUPLICATE of bug 444079
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 18:14 EDT by James Westby
Modified: 2008-07-31 14:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-31 14:44:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add an error dialog for rw_screen_new failure (1.43 KB, patch)
2008-04-24 18:14 EDT, James Westby
no flags Details | Diff

  None (edit)
Description James Westby 2008-04-24 18:14:07 EDT
Please see

https://bugs.edge.launchpad.net/ubuntu/+source/gnome-control-center/+bug/215396

The xrandr code doesn't check for a NULL return from rw_screen_new,
and so falls over.

The message returned here could be tweaked, we reused one to not break
string freeze, but it appears Fedora doesn't use l10n here, so that
might not be a consideration for you.

Thanks,

James
Comment 1 James Westby 2008-04-24 18:14:07 EDT
Created attachment 303699 [details]
Add an error dialog for rw_screen_new failure
Comment 2 Bug Zapper 2008-05-14 06:07:37 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Adam Jackson 2008-07-31 14:44:20 EDT

*** This bug has been marked as a duplicate of 444079 ***

Note You need to log in before you can comment on or make changes to this bug.