Bug 444095 - wpa_supplicant fails to connect to uni wifi AP
wpa_supplicant fails to connect to uni wifi AP
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 18:35 EDT by Jordan Mantha
Modified: 2008-08-19 14:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-19 14:46:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jordan Mantha 2008-04-24 18:35:45 EDT
I am trying to connect to my Uni's wifi using the following wpa_supplicant.conf:

eapol_version=1
ap_scan=1
fast_reauth=1

network={
       ssid="Wolfnet"
       scan_ssid=1
       key_mgmt=WPA-EAP
       eap=PEAP
       identity="<username>"
       password="<passwd>"
       ca_cert="/etc/pki/tls/certs/Equifax_Secure_CA.pem"
       phase2="auth=MSCHAPV2"
}

On Ubuntu 8.04 (wpa_supplicant 0.5.9 and 2.6.24 kernel) the above
wpa_supplicant.conf works. I tried the wpa_supplicant from FC8 (0.5.10) but
still no go. I have an Intel Corporation PRO/Wireless 3945ABG card with iwl3945
driver.
Comment 1 Dan Williams 2008-04-24 18:39:04 EDT
so some additional comments; I have wpa_supplicant detailed logs for both
Ubuntu, F9 + wpa_supplicant 0.5.10, and F9 + wpa_supplicant 0.6.3 sent to me by
the bug filer and can provide them if needed.

The problem appears to be that the driver keeps sending disconnect events at
inopportune times.  There are a ton more disconnect events with F9 than with
Ubuntu, and the fact that both wpa_supplicnat 0.5.10 and 0.6.3 show the same
symptoms indicates that it's more of a driver issue than a supplicant issue.
Comment 2 Dan Williams 2008-04-24 18:43:11 EDT
maybe install some debug kernels and enable debugging in modprobe.conf and get
some output as to why the driver sends the disconnects?

Comment 8 Bug Zapper 2008-05-14 06:07:50 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Mike C 2008-06-18 17:48:05 EDT
I originally had a lot of problems finding the correct form of the network block
to make a connection to my institution's wireless using peap with MSCHAPV2- I am
enclosing the lines below that I found worked for me eventually:
# York University eduroam network block
network={
        ssid="eduroam"
        scan_ssid=1
        proto=WPA RSN
        key_mgmt=WPA-EAP
        eap=PEAP
        pairwise=CCMP TKIP
        identity="myusername@york.ac.uk"
        password="mypassword"
        ca_cert="/etc/pki/tls/cert.pem"
        subject_match="/C=GB/L=York/O=University of York/OU=Computing
Service/OU=Terms of use at www.verisign.co.uk/rpa (c)05/OU=Authenticated by
VeriSign/OU=Member, VeriSign Trust Network/CN=nasaaa1.york.ac.uk"
        phase2="auth=MSCHAPV2"
#        priority=5
}

For me the proto and pairwise lines seemed to be needed before it would work.
Also I needed username@machinename rather than just username for the identity.
Might be worth trying in your case - it took me several months of fiddling
before I found the right combination of lines. Although this problem may have
other causes it would be worth ruling out a config file problem before chasing
deeper causes.
The subject_match line is not essential but it does confirm security certificate
validity.
Comment 10 John W. Linville 2008-07-08 15:58:24 EDT
Do you continue to experience this problem with current kernels?
Comment 11 John W. Linville 2008-08-19 14:46:39 EDT
Closed due to lack of response...

Note You need to log in before you can comment on or make changes to this bug.