Bug 444132 - Kernel panic - Unable to mount rootfs
Kernel panic - Unable to mount rootfs
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel-xen (Show other bugs)
4.7
ia64 Linux
low Severity high
: beta
: ---
Assigned To: Stephen Tweedie
Martin Jenner
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-25 05:59 EDT by Alexander Todorov
Modified: 2008-04-28 09:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 09:10:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full log from rebooting the system to kernel panic (7.88 KB, text/plain)
2008-04-25 05:59 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2008-04-25 05:59:37 EDT
Description of problem:
automated test cases for ia64 fail due to the following error:
RAMDISK: Compressed image found at block 0
RAMDISK: incomplete write (-28 != 32768) 12582912
VFS: Cannot open root device "<NULL>" or unknown-block(8,2)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,2)



Version-Release number of selected component (if applicable):
kernel-2.6.9-69.EL
anaconda-10.1.1.88-1

How reproducible:
100%

Steps to Reproduce:
1. Boot the installer (need more details here, will investigate how out test
cases run the installer)
2.
3.
  
Actual results:
Kernel panic

Expected results:
Install starts

Additional info:
* prior to that I have RHEL4-U6 on one machine and 5.2 on another
* seeing this on different machines/different test cases (although they should
start the install in the same manner)
* see full console log attached
Comment 1 Alexander Todorov 2008-04-25 05:59:37 EDT
Created attachment 303767 [details]
full log from rebooting the system to kernel panic
Comment 5 Luming Yu 2008-04-25 07:58:49 EDT
Sounds like HP box, adding Doug...
Is it able to be reproduced on other ia64 boxes?
Comment 9 Doug Chapman 2008-04-28 09:09:19 EDT
I thought we determined this was a problem with KATE and not an OS bug. 
However, since I can't see the private comments there is more to this than I
know.  Could someone enlighten me?
Comment 10 Alexander Todorov 2008-04-28 09:10:19 EDT
Sorry for the noise once again:

http://git.fedorahosted.org/git/anaconda.git?p=anaconda.git;a=commitdiff;h=7699ed181dfbf819e370889b86402fdd35a884cd

This commit didn't make it into the 88-1 build of anaconda. This is 2/2 patch
that's needed to fix bug #443373 (it is changing the default value for
ramdisk_size in the boot images). According to jgranado that's why we've been
seeing the kernel panic with 0424.0 tree. 
Comment 11 Alexander Todorov 2008-04-28 09:11:46 EDT
Doug,
the bug was reopened due to seeing the same behavior with Xen but comment #10
explains it all. 

Note You need to log in before you can comment on or make changes to this bug.