Bug 444135 - openbox sessions don't respect workspace configuration after GDM
openbox sessions don't respect workspace configuration after GDM
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openbox (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-25 06:36 EDT by Brad Walker
Modified: 2009-08-27 13:08 EDT (History)
6 users (show)

See Also:
Fixed In Version: 3.4.7.2-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-20 15:12:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Walker 2008-04-25 06:36:08 EDT
Description of problem:
The window manager only has one workspace titled "Workspace 1" if logged in
through GDM using the Openbox or GNOME/Openbox sessions. Openbox won't respect
the number of workspaces or their names in ~/.config/openbox/rc.xml.


Version-Release number of selected component (if applicable):
openbox-3.4.6.1-1.fc9.x86_64
Fedora 9-preview+


How reproducible: 100%


Steps to Reproduce:
1. Boot into run level 5 and GDM
2. Choose Openbox or GNOME/Openbox session
3. Login
  
Actual results: One workspace titled "Workspace 1"


Expected results: Four workspaces configured with names "1", "2", "3", and "4".


Additional info:
Openbox and gnome-openbox-session WILL configure the workspaces as described in
~/.config/openbox/rc.xml if the user logs in from run level 3 and does 'startx'
with the appropriate session in their .xinitrc.

Running 'openbox --replace' in a terminal after logging in through GDM into an
openbox session will print the following:
(openbox:2908): Openbox-WARNING **: Openbox is configured for 4 desktops, but
the current session has 1.  Overriding the Openbox configuration.

This problem probably happens because of some setting set by GDM.
Comment 1 Brad Walker 2008-04-27 01:28:45 EDT
These (latest) versions reproduce the problem:
openbox-3.4.7.1-1.fc9.x86_64
gdm-2.21.10-0.2008.04.24.1.fc9.x86_64
Comment 2 Miroslav Lichvar 2008-04-28 07:49:16 EDT
This is caused by metacity started in gdm which sets the number of desktops to 1.
I'll ask upstream about forcing openbox to change it even when set before.
Comment 3 Miroslav Lichvar 2008-05-07 06:10:46 EDT
Didn't get a response from openbox maintainers. Let's see if removing
_NET_NUMBER_OF_DESKTOPS property in gdm is a good idea.
Comment 4 Matthias Clasen 2008-05-08 17:54:42 EDT
You could simply do xprop -root -remove _NET_NUMBER_OF_DESKTOPS in your session
script before starting openbox. 
Comment 5 Bug Zapper 2008-05-14 06:08:54 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Miroslav Lichvar 2008-05-14 07:24:10 EDT
That wouldn't work for users that have $HOME/.xsession script.

I guess it's easier to force openbox to change the property. If gdm should clean
up the property, we can remove the patch later.
Comment 7 Brad Walker 2008-05-14 13:35:16 EDT
The code's in screen_startup, found in openbox/screen.c.

BTW, the xprop workaround didn't fix the workspace names.
Comment 8 Miroslav Lichvar 2008-05-15 08:10:18 EDT
Hm, there are other properties causing troubles, like _NET_DESKTOP_NAMES and
_NET_CURRENT_DESKTOP.

Ignoring _NET_CURRENT_DESKTOP in wm is probably a bad idea, so I'm reassigning
this back to gdm.
Comment 9 Matthias Clasen 2008-05-23 00:22:55 EDT
Its really not the job of gdm to clean this up, imo. 
If openbox has a configuration for the number of workspaces, it is its
responsibility to sync the property to its configuration at startup.
Comment 10 Miroslav Lichvar 2008-06-10 13:43:06 EDT
openbox-3.4.7.2-3 removes the three properties in session scripts.

This doesn't fix the problem for users with their own session script, so it
still would be nice to see this fixed in gdm. If the properties were ignored in
openbox, they wouldn't be preserved across openbox restarts and that would be
annoying.
Comment 11 Fedora Update System 2008-06-10 13:54:22 EDT
openbox-3.4.7.2-3.fc9 has been submitted as an update for Fedora 9
Comment 12 Fedora Update System 2008-06-11 00:36:48 EDT
openbox-3.4.7.2-3.fc9, obconf-2.0.3-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openbox obconf'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5198
Comment 13 Fedora Update System 2008-06-20 15:12:40 EDT
openbox-3.4.7.2-3.fc9, obconf-2.0.3-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 David Crowe 2008-08-14 02:08:40 EDT
(In reply to comment #13)
> openbox-3.4.7.2-3.fc9, obconf-2.0.3-2.fc9 has been pushed to the Fedora 9
> stable repository.  If problems still persist, please make note of it in this
> bug report.

this problem persists.

currently installed:

openbox-3.4.7.2-3.fc9.i386
obconf-2.0.3-2.fc9.i386
gdm-2.22.0-8.fc9.i386

on a fc8 install, this problem does _not_ exist with basically the same configuration but with the following packages installed (latest f8 updates):

openbox-3.4.7.2-2.fc8
obconf-2.0.3-2.fc8
gdm-2.20.5-3.fc8
Comment 15 Miroslav Lichvar 2008-08-14 04:48:36 EDT
Are you executing openbox in $HOME/.xsession script? If yes, try replacing openbox with openbox-session or add the following command to the script.

xprop -root -remove _NET_NUMBER_OF_DESKTOPS -remove _NET_DESKTOP_NAMES -remove _NET_CURRENT_DESKTOP
Comment 16 David Crowe 2008-08-14 13:38:16 EDT
i should have been more specific - i'm running from GDM as in the original report.  i've tried with both the Gnome and Gnome/Openbox sessions from the base F9 GDM install with the same results.

i can add workspaces interactively via openbox but after i logout and back in again it reverts back to the single workspace.  and yes, all session information is being saved for the restart.

as mentioned in comment #14, the same config and setup works just fine in f8.
Comment 17 Miroslav Lichvar 2008-08-15 08:08:26 EDT
Any chance that xorg-x11-utils package containing the xprop utility isn't installed on the system?
Comment 18 David Crowe 2008-08-15 09:39:31 EDT
(In reply to comment #17)
> Any chance that xorg-x11-utils package containing the xprop utility isn't
> installed on the system?

its installed too:

xorg-x11-utils-7.4-1.fc9.i386
Comment 19 Miroslav Lichvar 2008-08-20 06:07:20 EDT
Well, it's working fine here, with the same package versions as you have installed.

Can you try another user account to see if it's not caused by a gnome setting?

Also it would be interesting to see the output of "xprop -root > /tmp/xprop.out" added before the exec line in /usr/bin/openbox-gnome-session.
Comment 20 Adam Spiers 2009-04-12 10:58:04 EDT
FYI I have submitted this upstream, based on seeing exactly the same issue with a SUSE system:

http://bugzilla.icculus.org/show_bug.cgi?id=4040
Comment 21 Anthony Thyssen 2009-04-14 20:16:48 EDT
The problem persistant for fedora 10 as well

If gdm is doing something that could effect other clients later, then it is the natural responsibility for THAT PROGRAM to clean up after itself.

That is standard programming practice, and brushing it under the rug, is NOT a solution!
Comment 22 trevorlangas 2009-08-27 13:08:42 EDT
I think I had the same problem. I just reloaded metacity to stop anything else from interfering such as compiz with 'metacity --replace'. Then I ran 'openbox --replace' and I no longer get that error.

Note You need to log in before you can comment on or make changes to this bug.