Bug 444140 - apache.sh doesn't work with apache v2.2
Summary: apache.sh doesn't work with apache v2.2
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: rgmanager   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Marek Grac
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-25 12:07 UTC by Pavel V Martynenko
Modified: 2009-04-16 20:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 11:22:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ugly patch (1.01 KB, patch)
2008-04-25 12:07 UTC, Pavel V Martynenko
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1822342 None None None Never

Description Pavel V Martynenko 2008-04-25 12:07:04 UTC
Description of problem:
there is no Port directive in apache v2.2. But apache.sh tries to use Listen and
Port insted of "Listen ip:port proto".

Version-Release number of selected component (if applicable):
rgmanager-2.0.31-1.el5_1.1 & httpd-2.2.3-11.el5_1.3

How reproducible:
use /usr/share/cluster/apache.sh in cluster.conf

Steps to Reproduce:
1.
2.
3.
  
Actual results:
httpd doesn't start

Expected results:
working httpd server

Additional info:
Service Request: 1822342 - bug in /usr/share/cluster/apache.sh

Comment 1 Pavel V Martynenko 2008-04-25 12:07:04 UTC
Created attachment 303777 [details]
ugly patch

Comment 2 Marek Grac 2008-09-23 11:22:46 UTC
Resource agent can use both Listen and Port directives but it will not generate lines other then with Listen. If we will met 'Port' then it will be commented out. This description (and proposed patch) tends me to believe that this is not a bug.


Note You need to log in before you can comment on or make changes to this bug.