Bug 444152 - file monitoring in im-info-daemon
file monitoring in im-info-daemon
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-25 09:55 EDT by Matthias Clasen
Modified: 2008-06-26 22:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 22:24:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2008-04-25 09:55:57 EDT
The file monitoring in im-info-daemon is really pretty wrong. It
directly uses fam to set up some monitors, and then adds an idle to the
mainloop that checks for fam events and then sleeps for a second.

Can I recommend to use the file monitoring api that is provided by glib
since 2.16: GFileMonitor/GDirectoryMonitor. These use the best available
file notification mechanism (inotify, fam, fen, ...), integrate
automatically in the mainloop, and are very easy to set up.
Comment 1 Bug Zapper 2008-05-14 06:09:20 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Akira TAGOH 2008-06-26 22:23:29 EDT
Move to rawhide since this is the kind of feature.
Comment 3 Akira TAGOH 2008-06-26 22:24:59 EDT
Fixed in 0.101.0-1 or later.

Note You need to log in before you can comment on or make changes to this bug.