Bug 444155 - mkinitrd: support booting from KVM virtio devices
Summary: mkinitrd: support booting from KVM virtio devices
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-25 14:21 UTC by Mark McLoughlin
Modified: 2009-06-10 07:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-06-10 07:50:47 UTC


Attachments (Terms of Use)
0001-mkinitrd-handle-KVM-virtio-devices.patch (1.01 KB, patch)
2008-04-25 14:21 UTC, Mark McLoughlin
no flags Details | Diff

Description Mark McLoughlin 2008-04-25 14:21:01 UTC
If you run kvm-qemu with e.g. --drive if=virtio,boot=on,file=foo.img then the
guest must use the KVM virtio drivers to mount the root device.

KVM exposes its virtio devices to the guest over PCI, requiring the guest to use
the virtio_pci driver for device enumeration. The actual block device driver is
virtio_blk.

Currently, if you boot using virtio and then try and create new initrd, the
initrd will include virtio_blk, but not virtio_net.

virtio_blk is to virtio_pci as standard disk drives is to the core PCI code, and
as virtio_blk is to lguest's device enumeration code and as xen_blkfront is to
xenbus.

Where virtio_pci differs from the others, though, is that it's a module and not
built in.

Comment 1 Mark McLoughlin 2008-04-25 14:21:01 UTC
Created attachment 303790 [details]
0001-mkinitrd-handle-KVM-virtio-devices.patch

Comment 2 Mark McLoughlin 2008-04-25 14:38:41 UTC
(In reply to comment #0)

> Currently, if you boot using virtio and then try and create new initrd, the
> initrd will include virtio_blk, but not virtio_net.

... "but not virtio_pci" is what I meant

Comment 3 Jeremy Katz 2008-04-25 15:27:23 UTC
Applied and building for F9

Comment 4 Mark McLoughlin 2008-04-25 17:26:44 UTC
Just to be sure, I tried a kvm virtio install without this fix and it failed to
boot after the install because virtio_pci wasn't loaded

Tried again with the fix and it works fine


Comment 5 Bug Zapper 2008-05-14 10:09:26 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Bug Zapper 2009-06-10 00:26:23 UTC
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Mark McLoughlin 2009-06-10 07:50:47 UTC
Long since fixed


Note You need to log in before you can comment on or make changes to this bug.