Bug 444163 - [rfe] test transaction before rebooting
[rfe] test transaction before rebooting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-25 11:30 EDT by Don Zickus
Modified: 2008-10-27 12:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 12:34:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Zickus 2008-04-25 11:30:37 EDT
Description of problem:

So I tried upgrading from FC7 to F9 using the cool new 'preupgrade' feature.
Unfortunately my experience had some issues most of which could have been
resolved with a test transaction.  Here's a description of what I had to go through:

- ran the preupgrade app and rebooted
- anaconda said I had a dep problem (nas-lib seemed to have a multilib conflict)
- rebooted and manually copied nas-lib.i386 to the /var/cache/yum/.../anaconda..
- rebooted into rawhide, anaconda failed again, lack of disk space
- rebooted into the old kernel, did some gparted magic
- rebooted into rawhide, anaconda failed again with a dep problem for gparted
- rebooted into old kernel, remove the gparted apps I installed
- rebooted into rawhide, anaconda started installing everything (yeah!!!)
- hung during post install?? (after three days just rebooted) but that is a
separate issue

(of course there were a few more reboots in there too, but above is just the
simplified version)

As you can see rebooting back and forth between old system and new system sucks.
 It would be great if there was an optional button that allowed me to do the
test transaction and disk space check *before* rebooting into the new kernel.  


Version-Release number of selected component (if applicable):
preupgrade-0.9-2.fc7.noarch

How reproducible:
forgive me if i only tried this once
Comment 1 Paul W. Frields 2008-08-10 16:42:46 EDT
Triaged
Comment 2 Will Woods 2008-10-27 12:34:57 EDT
Thanks for the suggestion. I did try adding an RPM transaction test to preupgrade. It took several minutes to run (just like it does in anaconda), but it got differing results from the anaconda test. (These differences are due to several known and unknown factors - anaconda copying files to your install drive, differing RPM versions, etc. - that we can't avoid.)

So: preupgrade would spend a few minutes grinding at the disk and CPU, tell you everything was OK, and half the time the install *still* failed due to lack of disk space, just like before.

In short: it didn't help.

For preupgrade-0.9.8, it checks available disk space and does a best-guess estimate of the space you'll need to complete the install. It then *warns* you if you have low disk space, and tells you how much estimated disk space is needed. At that point, you can free up disk space and check again, or you can continue anyway and hope for the best.

It's just as accurate as the RPM transaction for the obvious cases - where you have plenty of disk, or far too little. For the gray area in the middle, it doesn't give false positives like the RPM transaction did. It also doesn't take 2-5 minutes to run.

So I'm going to close this as RAWHIDE - if you have ideas for refining the disk space checks any further, feel free to either reopen this bug or file a new one.

Note You need to log in before you can comment on or make changes to this bug.