Bug 444183 - F9 preview boot failed on nash, system is AMD X2 PATA+SATA HW RAID
F9 preview boot failed on nash, system is AMD X2 PATA+SATA HW RAID
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
9
i686 Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-25 13:51 EDT by Edmond Hui
Modified: 2009-02-17 07:54 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-17 07:54:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of system hangs (367.45 KB, image/gif)
2008-04-25 13:51 EDT, Edmond Hui
no flags Details

  None (edit)
Description Edmond Hui 2008-04-25 13:51:49 EDT
Description of problem:
F9 preview failed to boot after installed. It hangs w/ a init SIGSEGV (see
screenshot from F8 i686 install)

The system is:
ASUS A8V-E SE
AMD X2 3800+
Quamtum fireball AS 20GB PATA HDD
8x DVD drive
2 x WDC WC1600JS 160GB SATA HDD running on build in hw RAID1

Tried on F9 preview x86_64, F8 x86_64/i686 and seeing the same problem.

The system is currently running F6, but HDD is dying w/ lost interrupt.

Version-Release number of selected component (if applicable):
nash 6.0.19 from F9 preview

How reproducible:
100%

Steps to Reproduce:
1. install via DVD
2. reboot
  
Actual results:
system hangs @ boot up

Expected results:
boot success and system start up continue

Additional info:
Comment 1 Edmond Hui 2008-04-25 13:51:49 EDT
Created attachment 303806 [details]
screenshot of system hangs
Comment 2 Edmond Hui 2008-04-28 09:10:31 EDT
As I continue to debug the problem, I removed the SATA HDDs and install F9
preview again. The system then successfully booted. I connect the SATA HDDs back
to the system and the system continue to function. It looks like something goes
wrong during installation.
Comment 3 Bug Zapper 2008-05-14 06:10:26 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Hans de Goede 2009-02-17 07:54:20 EST
The backtrace seen in the attached image is a known problem with how mkinitrd handles dmraid sets, which is fixed in mkinitrd-6.0.78, which will show uop in rawhide soon. Due to invasive nature of the changes fixing this, an update fixing this for F-9 (nor F-10) is not very likely.

Note You need to log in before you can comment on or make changes to this bug.