Bug 44419 - Network connection drops approx 55mins to 1hr
Network connection drops approx 55mins to 1hr
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-06-13 11:56 EDT by penguins
Modified: 2015-01-04 17:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-25 02:19:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description penguins 2001-06-13 11:56:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
I am running a Thinkpad 600x using the yenti pcmcia driver and ibmtr_cs 
for my turbo token ring card 2 network adapter.  What happens is like 
clock work every 55 minutes to an hour, my keyboard will no longer type, 
and my machine will be dropped from the network.  The interesting part is, 
my machine can still use the mouse allowing me to reboot the box 
gracefully.  I've tried booting linux with apm=off and that did not help 

How reproducible:

Steps to Reproduce:
1.boot machine
2.run X for around an hour
3.will lockup 

Actual Results:  I can run any given apps, I typicall am running x3270, 
netscape and xchat.  After an hour, the keyboard doesn't type, the caps 
lock won't light when tapped.  Try to ping from another machine, machine 
has dropped off the network.

Expected Results:  Machine should not drop from network and the keyboard 
shouldn't get dropped either.

Additional info:

I've tried this with 2 different NIC's on two different networks.  I've 
tried just the turbo 16/4 nic with the same results
Comment 1 Arjan van de Ven 2001-06-13 12:02:33 EDT
Can you try the following:

rm /etc/cron.d/kmod
service crond restart

sounds like 1) cron is involved ('like clockwork') and the removal of a module
could cause what you're describing.
Comment 2 penguins 2001-06-13 13:55:21 EDT
this did not fix it.  It occurred around the same time frame.  I had 
xscreensaver locking my screen when I went to lunch, came back and was unable 
to type my password or switch virtual consoles.
Comment 3 penguins 2001-06-14 11:20:24 EDT
looks like something assigned the tokenring card to a conflicting interrupt. 
Forced interrupt, ringspeed, and sramsize has fixed it.

Note You need to log in before you can comment on or make changes to this bug.