Bug 444203 - Manually partitioning sets /boot/efi to vfat not efi
Manually partitioning sets /boot/efi to vfat not efi
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
ia64 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
Deferred to F10
:
Depends On:
Blocks: f9-ia64-blocker
  Show dependency treegraph
 
Reported: 2008-04-25 15:27 EDT by Glen A. Foster
Modified: 2009-07-14 14:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 14:15:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen A. Foster 2008-04-25 15:27:40 EDT
Description of problem: I tried manually partitioning a 146GB drive with the
latest FC9 beta (ia64).  I created boot, root, and swap on /dev/sdb as follows:

┌────────────────────────────┤ Partitioning ├────────────────────────────┐   
│                                                                        │   
│      Device        Start    End     Size       Type     Mount Point    │   
│ /dev/sda                                                             ↑ │   
│   sda1                  1      13     100M  vfat                     ▮ │   
│   sda2                 13    3838   30000M  ext3                     ▒ │   
│   sda3               3838    4882    8192M  swap                     ▒ │   
│   sda4               4882    6870   15590M  Foreign                  ▒ │   
│   sda5               6870    8925   16124M  Foreign                  ▒ │   
│ /dev/sdb                                                             ▒ │   
│   sdb1                  1    4462   35000M  ext3        /            ▒ │   
│   sdb2               4462    4985    4096M  swap                     ▒ │   
│   sdb3               4985    5009     190M  vfat        /boot/efi    ↓ │   
│                                                                        │   
│    ┌─────┐   ┌──────┐   ┌────────┐   ┌──────┐   ┌────┐   ┌──────┐      │   
│    │ New │   │ Edit │   │ Delete │   │ RAID │   │ OK │   │ Back │      │   
│    └─────┘   └──────┘   └────────┘   └──────┘   └────┘   └──────┘      │   
│                                                                        │   
│                                                                        │   
└────────────────────────────────────────────────────────────────────────┘   

... note the size of /boot/efi.  Then I tabbed over to "OK" and pressed ENTER:

┌────────────────────────────┤ Partitioning ├────────────────────────────┐   
│                                                                        │   
│      Device ┌────────┤ Error with Partitioning ├─────────┐unt Point    │   
│ /dev/sda    │                                            │           ↑ │   
│   sda1      │ The following critical errors exist with   │           ▮ │   
│   sda2      │ your requested partitioning scheme.        │           ▒ │   
│   sda3      │ These errors must be corrected prior to    │           ▒ │   
│   sda4      │ continuing with your install of Fedora.    │           ▒ │   
│   sda5      │                                            │           ▒ │   
│ /dev/sdb    │ You must create an EFI System Partition    │           ▒ │   
│   sdb1      │ of type FAT and a size of 50 megabytes.    │           ▒ │   
│   sdb2      │                                            │           ▒ │   
│   sdb3      │                  ┌────┐                    │ ot/efi    ↓ │   
│             │                  │ OK │                    │             │   
│    ┌─────┐  │                  └────┘                    │ ─────┐      │   
│    │ New │  │                                            │ Back │      │   
│    └─────┘  │                                            │ ─────┘      │   
│             └────────────────────────────────────────────┘             │   
│                                                                        │   
└────────────────────────────────────────────────────────────────────────┘   

At Doug Chapman's suggestion, I tried adding a 150MB /boot (ext3) partition, but
that also got the same error-message about partitioning configuration errors.

If I go back and let anaconda auto-partition /dev/sdb, it works.

Version-Release number of selected component (if applicable):
# rpm -q anaconda
anaconda-11.4.0.75-1

How reproducible: 100% (always)
Comment 1 Jeremy Katz 2008-04-25 15:44:11 EDT

*** This bug has been marked as a duplicate of 444127 ***
Comment 2 Peter Jones 2008-04-25 15:54:29 EDT
So you partitioned manually then?  If so, can you see if it gives you an "efi"
option instead of "vfat" for sdb3?  If so, select that and hopefully that'll
work.  In that case I'll need to figure out why it's not automatically selecting
it.  If not, we need to figure out why it's not in the list.
Comment 3 Glen A. Foster 2008-04-25 16:17:02 EDT
Hey, Peter; long time no see. :)  Yes, I manually partitioned the last install.
 Not only that, this is a TEXT-MODE install over serial console; sorry I forgot
to mention that last time.

When I install, I get the following (alphbetized) list of options:
efi, ext2, ext3, physical volume (LVM), software RAID, swap, vfat, xfs
(the 'Add Partition') screen defaults to "ext3" on serial installs, always.  I
dunno what the graphical installer does - I haven't tried it.

*** USING "efi" as the partition-type for /boot/efi allows me to proceed ***
Comment 4 Peter Jones 2008-04-25 16:36:55 EDT
Hey, Glen.

While I'd really prefer for it to automatically be set to "efi" if you select
that mountpoint, I'm going to defer this to post-F9 -- auto-partitioning works*,
and manually partitioning works if you know to select efi.  At this stage,
that's good enough that it's better to not mess with the code.

(* I don't have an Itanium in front of me, but on i386 autopart correctly sets
it to "efi" and the resulting EFI System Partition is boot.)
Comment 5 Doug Chapman 2008-04-25 16:45:58 EDT
Peter,

Since we plan on shipping F9 final for ia64 a little bit after F9 for the
primary arches could we get this into anaconda just after you guys ship the
primary F9?  That way F9 final for ia64 could pick up the fix.

I am expecting our F9 final will be in about a month.  We just wrapped up
F9-beta just now (which is what Glen was using when he hit this).
Comment 6 Peter Jones 2008-04-25 16:59:44 EDT
Doug, that may be feasible.  I'm really not sure just yet, what with the office
move right in the middle and whatnot.
Comment 7 Bug Zapper 2008-05-14 06:10:45 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Chris Ward 2009-04-06 05:30:15 EDT
~Attention~

This bug appears to pertain to an important F11 feature, EFI, which the Fedora Community will be testing in an upcoming Fedora Test Day. Your participation in the action would be greatly appreciated!

More information:
https://fedoraproject.org/wiki/QA/Test_Days/2009-04-09
https://fedoraproject.org/wiki/Features/EFI
Comment 9 Bug Zapper 2009-06-09 20:27:00 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2009-07-14 14:15:46 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.