Bug 444236 - snmpwalk spikes cpu if IPv6 disabled on X86_64 RHEL 5.2Beta
snmpwalk spikes cpu if IPv6 disabled on X86_64 RHEL 5.2Beta
Status: CLOSED DUPLICATE of bug 431977
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-snmp (Show other bugs)
5.2
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-25 17:58 EDT by Michael Stahnke
Modified: 2008-04-28 11:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 09:51:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is a slightly sanitized version of our snmpd.conf (4.98 KB, application/octet-stream)
2008-04-25 17:59 EDT, Michael Stahnke
no flags Details
The output of snmpwalk (not straced anything) (21.06 KB, text/plain)
2008-04-25 17:59 EDT, Michael Stahnke
no flags Details
The output from top showing a cpu is 100% used (1.18 KB, text/plain)
2008-04-25 18:00 EDT, Michael Stahnke
no flags Details
strace running with snmpwalk (292.74 KB, text/plain)
2008-04-25 18:00 EDT, Michael Stahnke
no flags Details
And a bit of /var/log/messages (1.90 KB, text/plain)
2008-04-25 18:01 EDT, Michael Stahnke
no flags Details

  None (edit)
Description Michael Stahnke 2008-04-25 17:58:30 EDT
Description of problem:
If you have disabled ipv6 on RHEL 5 x86_64 via the modprobe.conf, running 
snmpwalk -v2c -c community  127.0.0.1 will spike a single CPU.  

Version-Release number of selected component (if applicable):
This is applicable to every release of net-snmp since 5.1 ISOs were released. 
The lastest version I have tried is is in the RHEL 5.2 Beta channel. 
net-snmp-5.3.1-2


How reproducible:
Always

Steps to Reproduce:
1.  Run RHEL 5.1 or newer x86_64
2.  Disable IPv6 via the modprobe.conf
3.  reboot
4.  service snmpd start
5.  snmpwalk -v2c -c community  127.0.0.1
6.  Look at top output, watch a CPU sit at 100%
  
Actual results:
I have included attachments for the commands. 

Expected results:
Not having 100% spike while snmpd is running.  

Additional info:

It appears to be happening on at least these MIBS
.1.3.6.1.2.1.4.34

.1.3.6.1.2.1.4.35


I have included the following:
snmpd.conf 
snmpwalk_output_normal
strace_snmpwalk
var_log_messages_snip
output_from_top

I also tried to rebuild the SRPM disabling Ipv6, but the build fails.  I am not
sure if that is considered a bug though. 


It appears that this bug isn't new.  Google told me it's been happing in Centos
4, and 5 also.  

Here's a link with some information from the CentOS crew. 

http://bugs.centos.org/view.php?id=1350
Comment 1 Michael Stahnke 2008-04-25 17:59:29 EDT
Created attachment 303824 [details]
This is a slightly sanitized version of our snmpd.conf
Comment 2 Michael Stahnke 2008-04-25 17:59:56 EDT
Created attachment 303825 [details]
The output of snmpwalk (not straced anything)
Comment 3 Michael Stahnke 2008-04-25 18:00:27 EDT
Created attachment 303826 [details]
The output from top showing a cpu is 100% used
Comment 4 Michael Stahnke 2008-04-25 18:00:50 EDT
Created attachment 303827 [details]
strace running with snmpwalk
Comment 5 Michael Stahnke 2008-04-25 18:01:06 EDT
Created attachment 303828 [details]
And a bit of /var/log/messages
Comment 6 Brian 2008-04-28 09:00:21 EDT
I see the same bug. Additionally, snmpd must be restarted after a snmpwalk of
the server to get snmpget's or walks working again.

Some people have reported this is a xen kernel issue, but this happens for us on
non-xen kernels.
Comment 7 Jan Safranek 2008-04-28 09:51:29 EDT
It should be already fixed in RHEL 5.2. It has nothing to do with xen and it
happens only with RHEL 5.1 (I've added a buggy patch there).

*** This bug has been marked as a duplicate of 431977 ***
Comment 8 Michael Stahnke 2008-04-28 10:17:21 EDT
This is not fixed in the currently released net-snmp inthe RHEL 5.2 beta channel.  

I have the latest net-snmp installed that is available in RHN. 
net-snmp-5.3.1-22

If there is a fix, could you direct me to the link?  The other bug says proposed
for RHEL 5.3.  I would like a fix before 2009.  
Comment 9 Jan Safranek 2008-04-28 10:49:24 EDT
it was fixed after beta, in net-snmp-5.3.1-23 to be precise. And the bug has
been evaluated as important enough to fix it in 5.2.

You can find test build at http://people.redhat.com/jsafrane/bugs/444236/
Comment 10 Michael Stahnke 2008-04-28 11:35:23 EDT
Thank you very much for a prompt response. Everything working just fine. 

Note You need to log in before you can comment on or make changes to this bug.