This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 444271 - postgresql doesn't Require: matching release of postgresql-libs
postgresql doesn't Require: matching release of postgresql-libs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-26 06:31 EDT by Juha Tuomala
Modified: 2013-07-02 23:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: 8.3.3-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-13 10:28:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Juha Tuomala 2008-04-26 06:31:08 EDT
Description of problem:

The following has been done with yum:

rpm -qa --qf="%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n" |grep postgresql
postgresql-libs-8.2.6-1.fc8.x86_64
postgresql-8.2.7-1.fc8.x86_64
postgresql-server-8.2.7-1.fc8.x86_64

Expected results:

Same versions.
Comment 1 Tom Lane 2008-04-26 12:53:12 EDT
Hm, how did you get into this state ... did you do a "yum update" on postgresql-server only?

It looks like the base and server packages fail to require the libs package to be the exact same subrelease.  
I don't believe the configuration you have is "broken" exactly, but it's probably desirable to have the 
subpackages all get updated concurrently.
Comment 2 Juha Tuomala 2008-04-26 17:47:35 EDT
Yep, I've been lazy and just picked one package and thought that deps will take 
care the rest but didn't. Same happened with cups and bzip2.
Comment 3 Tom Lane 2008-04-26 18:58:36 EDT
OK, I'll tighten up the cross-package Requires.
Comment 4 Devrim GUNDUZ 2008-04-27 18:34:28 EDT
Tom, could you duplicate this? yum should have also upgraded -libs package,
since there is a new package that provides libpq.so.

I did not test though.
Comment 5 Tom Lane 2008-04-28 15:47:15 EDT
Verified --- "yum update postgresql-server" only updates the server and base packages, not libs.  I 
wouldn't have expected anything different; if I tell yum what to update, it shouldn't update anything that 
it's not directly required to by dependencies.
Comment 6 Tom Lane 2008-04-28 19:39:12 EDT
Done in CVS HEAD (F-10 to be).  Not sure when I'll get round to propagating this into the back branches.
Comment 7 Juha Tuomala 2008-04-29 02:15:17 EDT
Thanks :) I'm happy that it got fixed for the future at least.

Just wondering that how many of this kind pkgs are out there.
Comment 8 Fedora Update System 2008-06-11 16:42:33 EDT
postgresql-8.3.3-1.fc9 has been submitted as an update for Fedora 9
Comment 9 Fedora Update System 2008-06-12 22:22:54 EDT
postgresql-8.3.3-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Juha Tuomala 2008-06-13 10:13:05 EDT
mmm...This bug was filed against f8. It still exists in f8 with the recent 
pgsql pkg updates.

For multi-release issues there is the cloning function:
https://bugzilla.redhat.com/enter_bug.cgi?cloned_bug_id=444271
Comment 11 Tom Lane 2008-06-13 10:28:35 EDT
I don't intend to fix it in F8.  Kindly don't make random replacements of bug subject lines ...
Comment 12 Juha Tuomala 2008-06-13 10:48:08 EDT
>   What    |Removed                     |Added
> ----------------------------------------------------------------
>  Summary|broken dependencies         |postgresql doesn't Require:

> I don't intend to fix it in F8.

F8 *is* current release. If you want to kill it, I suggest to take it
into fedora-devel mailing list. 

> Kindly don't make random replacements of bug subject lines ...

How about adding the product and Cc fields into subject too? 

Note You need to log in before you can comment on or make changes to this bug.