Bug 444280 - Htop doesn't appear when run from the Gnome menu.
Summary: Htop doesn't appear when run from the Gnome menu.
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: htop   
(Show other bugs)
Version: 8
Hardware: x86_64 Linux
low
low
Target Milestone: ---
Assignee: Rafał Psota
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-26 13:53 UTC by Joonas Sarajärvi
Modified: 2008-06-08 12:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-08 12:27:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joonas Sarajärvi 2008-04-26 13:53:51 UTC
Description of problem:
If I run Htop from Gnome's main menu; Applications->System Tools->Htop, nothing
seems to happen. I guess this might be due to a fault in file
/usr/share/applications/fedora-htop.desktop . In the desktop file, is a line:
Exec=htop. I think it runs Htop, but the program doesn't appear since it doesn't
have a terminal.

I remember having this working sometime in the past, but can't remember when it
started to behave like this.

Version-Release number of selected component (if applicable):
htop.x86_64 0.7-1.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Select Applications->System Tools->Htop from the Gnome main menu.
  
Actual results:
Nothing happens.

Expected results:
Htop should open in a terminal.

Additional info:

Comment 1 Fedora Update System 2008-04-27 12:27:47 UTC
htop-0.7-2.fc8 has been submitted as an update for Fedora 8

Comment 2 Rafał Psota 2008-04-27 13:14:10 UTC
Indeed there was a bug in desktop file. Terminal=true was missing. It should be
ok now.

Comment 3 Fedora Update System 2008-04-29 20:49:54 UTC
htop-0.7-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update htop'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-3303

Comment 4 Joonas Sarajärvi 2008-04-29 22:19:38 UTC
The package seems to not have been synced to the mirrors, but I downloaded the
same package (I think) from koji.fedoraproject.org. The menu item works now as I
think it should work. Thanks for the fix.


Note You need to log in before you can comment on or make changes to this bug.