Bug 444287 - Obsolete packages marked as essential in rpmpriorities (yet again)
Obsolete packages marked as essential in rpmpriorities (yet again)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: apt (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
: Patch
: 426143 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-26 12:37 EDT by Kevin Kofler
Modified: 2009-01-14 22:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 22:11:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
current rpmpriorities for F9 (345 bytes, text/plain)
2008-04-26 12:39 EDT, Kevin Kofler
no flags Details

  None (edit)
Description Kevin Kofler 2008-04-26 12:37:52 EDT
Description of problem:
There are obsolete packages marked as essential in 
apt's /etc/apt/rpmpriorities. Some, like sysvinit, have been newly obsoleted 
in F9, some, like hotplug, have been obsolete for ages. There's also the case 
of kudzu, which still exists, but can no longer be considered "essential" (and 
it's likely to be dropped entirely in F10).

I'm attaching the current list.

Version-Release number of selected component (if applicable):
apt-0.5.15lorg3.94-3.fc9 

Additional info:
I'm not sure it makes sense to define "Essential" packages at all in Fedora. 
It invariably causes problems when upgrading from one release to the next, 
because obsolete packages will be held back from getting replaced. Fedora 
changes its base system very often, so the list tends to bitrot rapidly.
Comment 1 Kevin Kofler 2008-04-26 12:39:45 EDT
Created attachment 303853 [details]
current rpmpriorities for F9

Here's the current list: dropped packages removed, replaced packages replaced
with what obsoletes them, kudzu dropped as no longer essential.
Comment 2 Kevin Kofler 2008-04-26 23:42:53 EDT
And with the latest upstart and initscripts builds for F9, you can drop 
event-compat-sysv from the list again, it's already obsolete:
http://koji.fedoraproject.org/koji/buildinfo?buildID=47333
http://koji.fedoraproject.org/koji/buildinfo?buildID=47334
I guess this kinds proves my point that this list is unmaintainable. ;-)
Comment 3 Bug Zapper 2008-05-14 06:12:47 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Kevin Kofler 2008-11-26 05:43:45 EST
*** Bug 426143 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2009-01-07 03:05:08 EST
apt-0.5.15lorg3.95-0.git416.3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/apt-0.5.15lorg3.95-0.git416.3.fc10
Comment 6 Fedora Update System 2009-01-07 16:52:23 EST
apt-0.5.15lorg3.95-0.git416.3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update apt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0304
Comment 7 Fedora Update System 2009-01-14 22:10:42 EST
apt-0.5.15lorg3.95-0.git416.3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.