Bug 444299 - libpciaccess causes hang when X starts
Summary: libpciaccess causes hang when X starts
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libpciaccess   
(Show other bugs)
Version: 9
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-26 19:27 UTC by Martin Ebourne
Modified: 2009-05-07 23:20 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 23:20:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin Ebourne 2008-04-26 19:27:44 UTC
Description of problem:
Upgraded libpciaccess on an otherwise fully up to date Fedora 9 Prerelease
system, causes X to hang on start.

Version-Release number of selected component (if applicable):
libpciaccess-0.10-2.fc9@x86_64 breaks
libpciaccess-0.10-1.fc9@x86_64 works fine

How reproducible:
Every time

Steps to Reproduce:
1. Boot system with libpciaccess-0.10-2.fc9 installed
  
Actual results:
When X starts at the end (rhgb not installed) it changes to the graphical mode
and completely hangs the system. The picture is whatever was there from before
it booted with some corruption.

Expected results:
GDM login screen.

Additional info:
I'm using the radeonhd driver:
xorg-x11-drv-radeonhd-1.1.0-0.7.20080404git.fc9.x86_64

Comment 1 Bug Zapper 2008-05-14 10:13:20 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Martin Ebourne 2008-05-19 23:00:09 UTC
Has anyone looked at this? I'm still having to run with the old libpciaccess but
the new one has shipped with F9. Probably other radeonhd users have this problem
but don't realise the cause.

Comment 3 Adam Jackson 2009-02-10 19:23:06 UTC
How's 0.10.3 working for you?

Comment 4 Martin Ebourne 2009-05-07 23:20:43 UTC
Confirmed libpciaccess-0.10.5-1 and xorg-x11-drv-radeonhd-1.2.5-2.8.20090411git from rawhide (F11) are working fine. No longer have a F9 system to test with.


Note You need to log in before you can comment on or make changes to this bug.