Bug 444326 - adjusting level via mouse wheel may cause the control to mute
adjusting level via mouse wheel may cause the control to mute
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pavucontrol (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-27 01:21 EDT by David Timms
Modified: 2008-06-04 03:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 03:59:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
example result of mouse scrolling the level up and down. (30.96 KB, image/png)
2008-04-27 01:21 EDT, David Timms
no flags Details

  None (edit)
Description David Timms 2008-04-27 01:21:01 EDT
Description of problem:
sometimes when the mouse wheel is used to adjust a volume level, turning it all
the way down, might cause the mute to become activated and the level control
disabled.

Version-Release number of selected component (if applicable):
pavucontrol-0.9.6-1.fc9.i386

How reproducible: occurs as you hit 0%.

Steps to Reproduce:
1. pavucontrol|output devices
2. put the mouse over the level control bar, and use the scroll up/down, or use
the keyboard left right or up/down to adjust the level
3. move to the left 0% end.
4. move back to the right.
  
Actual results:
- the level jumps to 5%, or however much changes you made after hitting 0%
- after 0.3 seconds,
- the mute button activates
- the level control becomes disabled.
- you can no longer adjust the level.

Expected results:
- mute is separate to level control - one should not affect the other.
- mute status should be shown with the mute button, not with the level graph.

Additional info:
- seems to be dependent on how fast I move back away from 0%
- seems to be dependent on whether the level step {10% for scroll wheel} is
aligned with the current level. if I am on 8% and step down, then up a few
times, then it might not occur.

- if I'm at 70% and I mute, I should be able to set the level to 50% and then
unmute, and the level control will be at 50%
- if I'm at 70% and I mute, I should be able to set the level to 90% and then
unmute, and the level control will be at 90%.

I may have also seen this in gnome-volume control.
Comment 1 David Timms 2008-04-27 01:21:01 EDT
Created attachment 303891 [details]
example result of mouse scrolling the level up and down.
Comment 2 Lennart Poettering 2008-05-02 10:45:21 EDT
Are you runnin the gnome mixer applet at the same time? Or some other mixer
tool? Please terminate those and try again. I am pretty sure this is not a bug
in pavucontrol but in those other volume controls.
Comment 3 Bug Zapper 2008-05-14 06:14:50 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Lennart Poettering 2008-06-04 03:59:38 EDT
I am pretty sure that this is unrelated to PA but caused by some other mixer
running in parallel, most likely the GNOME mixer applet or GNOME volume control.
Since I got not feedback on this I am closing this now. Feel free to reopen when
this problem persists and is unrelated to those mixers.

Note You need to log in before you can comment on or make changes to this bug.