Bug 444337 - NM edit wifi connections won't allow to save the changes
NM edit wifi connections won't allow to save the changes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: NMF9Blockers
  Show dependency treegraph
 
Reported: 2008-04-27 09:05 EDT by Samuele Farfarini
Modified: 2008-04-30 19:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 19:06:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samuele Farfarini 2008-04-27 09:05:38 EDT
Description of problem:


Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.9.2.svn3566.fc9.i386
NetworkManager-gnome-0.7.0-0.9.2.svn3566.fc9.i386
NetworkManager-glib-0.7.0-0.9.2.svn3566.fc9.i386
kernel-2.6.25-8.fc9.i686

How reproducible:
Just using the NetworkManager applet. Only for wifi connection (i also tried
with wired and vpn, and all works fine).

Steps to Reproduce:
1. Right click on NetworkManager applet, and choose Edit Connection
2. choose Wireless, and so Add (or select an existing connection and press
Modify, is the same)
3. Edit whatever you want, add or remove information as you mean.
  
Actual results:
Modify or create connection preference is simply impossible because the OK
button is always deactivated, in all case and with all possible option status.

Expected results:
Click OK to apply changes to connection preference, and so just use it :)

Additional info:
Using an ipw2100 interface, named eth1, and tried to change preferences in
system-config -network, activeting or deactivating "controlled by network
manager" flag, or adding or removing connection, o modifying the flag "user can...."
Nothing happened to network manager.
Just tried on a fresh and default install of fedora 9-preview, updated with yum.
Comment 1 Dan Williams 2008-04-28 00:30:44 EDT
reproduced, will fix.
Comment 2 Dan Williams 2008-04-28 01:26:32 EDT
fixed upstream in applet r704
Comment 3 Dan Williams 2008-04-30 19:06:10 EDT
in latest koji builds

Note You need to log in before you can comment on or make changes to this bug.