Bug 444377 - fontforge crashes by missing -ibm-courier-medium-.. fonts on F8->F9 system.
fontforge crashes by missing -ibm-courier-medium-.. fonts on F8->F9 system.
Status: CLOSED DUPLICATE of bug 450709
Product: Fedora
Classification: Fedora
Component: xorg-x11-fonts (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-27 21:39 EDT by Caius Chance
Modified: 2008-06-21 09:15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-21 09:15:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Caius Chance 2008-04-27 21:39:40 EDT
Description of problem:
fontforge crashes by missing -ibm-courier-medium-.. fonts on F8->F9 system. It
has the following error messages right after the splash screen has flashed on
the desktop:

$ LANG=en_US.UTF-8 fontforge
Copyright (c) 2000-2008 by George Williams.
 Executable based on sources from 22:48 GMT 9-Mar-2008.
 Library based on sources from 22:48 GMT 9-Mar-2008.
Help! Server claimed font
	-ibm-courier-medium-r-normal--12-0-0-0-m-0-iso10646-1
 existed in the font list, but when I asked for it there was nothing.
 I may crash soon.
セグメンテーション違反です

Version-Release number of selected component (if applicable):
fontforge-20080309-1.fc9.i386

How reproducible:
Always.

Steps to Reproduce:
1. Installed fontforge rpm on F8->F9 system.
2. Start gnome-terminal by Alt-F2 > 'gnome-terminal'.
3. Input fontforge.
4. Check results.
  
Actual results:
fontforge started.

Expected results:
fontforge crashed with error messages.

Additional info:
N/A.
Comment 1 Caius Chance 2008-04-27 21:49:10 EDT
Removal of entries in /usr/share/X11/Type1/fonts.dir does resolve the problem:

cour.pfa -ibm-courier-medium-r-normal--0-0-0-0-m-0-iso10646-1
cour.pfa -ibm-courier-medium-r-normal--0-0-0-0-m-0-iso8859-1
cour.pfa -ibm-courier-medium-r-normal--0-0-0-0-m-0-iso8859-3
cour.pfa -ibm-courier-medium-r-normal--0-0-0-0-m-0-iso8859-9
courb.pfa -ibm-courier-bold-r-normal--0-0-0-0-m-0-iso10646-1
courb.pfa -ibm-courier-bold-r-normal--0-0-0-0-m-0-iso8859-1
courb.pfa -ibm-courier-bold-r-normal--0-0-0-0-m-0-iso8859-3
courb.pfa -ibm-courier-bold-r-normal--0-0-0-0-m-0-iso8859-9
courbi.pfa -ibm-courier-bold-i-normal--0-0-0-0-m-0-iso10646-1
courbi.pfa -ibm-courier-bold-i-normal--0-0-0-0-m-0-iso8859-1
courbi.pfa -ibm-courier-bold-i-normal--0-0-0-0-m-0-iso8859-3
courbi.pfa -ibm-courier-bold-i-normal--0-0-0-0-m-0-iso8859-9
couri.pfa -ibm-courier-medium-i-normal--0-0-0-0-m-0-iso10646-1
couri.pfa -ibm-courier-medium-i-normal--0-0-0-0-m-0-iso8859-1
couri.pfa -ibm-courier-medium-i-normal--0-0-0-0-m-0-iso8859-3
couri.pfa -ibm-courier-medium-i-normal--0-0-0-0-m-0-iso8859-9
Comment 2 Bug Zapper 2008-05-14 06:16:45 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Nicolas Mailhot 2008-06-21 09:15:52 EDT

*** This bug has been marked as a duplicate of 450709 ***

Note You need to log in before you can comment on or make changes to this bug.