Bug 444387 - vim doesn't own /usr/share/vim/vimfiles
vim doesn't own /usr/share/vim/vimfiles
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-28 00:54 EDT by Geoff Reedy
Modified: 2008-11-03 08:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-03 08:49:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geoff Reedy 2008-04-28 00:54:36 EDT
I can't see any way to bring to anyone's attention an already filed bug as I can't reopen it. Whomever 
can, feel free to close this one as a duplicate of the original and reopen the original. I believe I have 
addressed the concern that caused the original to be closed as wontfix.

+++ This bug was initially created as a clone of Bug #219154 +++

Description of problem:
Neither vim-common package nor any other package from vim src.rpm owns
/usr/share/vim/vimfiles directory, which seems to be (by :he 'rtp') supposed to
be place for vim plugins to be installed. Actually, this directory doesn't exist
in RHEL5b2/FC[56]. When trying to create additional vim plugin (see bug 217836)
which should be installed there, there is no package which would own
/usr/share/vim/vimfiles/*/ direcotries and /usr/share/vim/vimfiles/ itself.

Version-Release number of selected component (if applicable):
vim-common-7.1.245-1.fc8

How reproducible:
100%


  
Actual results:
no package owns /usr/share/vim/vimfiles and its subdirectories (copy of
subdirectories of /usr/share/vim/vim70/).

Expected results:
they should be owned by vim-common, IMHO.

Additional info:

-- Additional comment from geoff@programmer-monk.net on 2008-02-05 23:14 EST --
(In reply to comment #6)
> I can't and won't add rtp paths for external vim plugins as there is no defined
> directory structure which all are supposed to use. Each one can make up its own
> subdirs.

I would like to reopen this bug. I am packaging scala which provides vim syntax
files. Vim clearly defines which directories should be present inside of
/usr/share/vim/vimfiles and I see no reason why vim-common should not create and
own these directories (the windows installer for vim does, by the way). rtp just
specifies the roots of the vim runtime directories, no need to add anything
extra to it, /usr/share/vim/vimfiles is enough.  Here's a list from :help 'rtp'

          autoload/     automatically loaded scripts |autoload-functions|
          colors/       color scheme files |:colorscheme|  
          compiler/     compiler files |:compiler|
          doc/          documentation |write-local-help|
          ftplugin/     filetype plugins |write-filetype-plugin|
          indent/       indent scripts |indent-expression|
          keymap/       key mapping files |mbyte-keymap|
          lang/         menu translations |:menutrans|
          plugin/       plugin scripts |write-plugin|
          print/        files for printing |postscript-print-encoding|
          spell/        spell checking files |spell|
          syntax/       syntax files |mysyntaxfile|
          tutor/        files for vimtutor |tutor|

Each of these directories should be created under /usr/share/vim/vimfiles and
/usr/share/vim/vimfiles/after and owned by vim-common
Comment 1 Karsten Hopp 2008-11-03 08:49:25 EST
I've added those directories in vim-7.2.026-2.fc10

Note You need to log in before you can comment on or make changes to this bug.