Bug 444395 - VMMouse mouse movement broken
VMMouse mouse movement broken
Status: CLOSED DUPLICATE of bug 434807
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vmmouse (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-28 02:44 EDT by Michael Monreal
Modified: 2008-09-10 10:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 10:55:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf (24.68 KB, image/png)
2008-04-28 02:48 EDT, Michael Monreal
no flags Details
xorg log (34.40 KB, image/png)
2008-04-28 02:50 EDT, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2008-04-28 02:44:06 EDT
Originally reported on bug #434807, but looks like this is unrelated after all:

"I recently installed Fedora9Pre on KVM. After setting the mouse to use the
vmmouse driver, all mouse actions (moving, pressing) only result in horizontal
movement of the mouse pointer to the right."
Comment 1 Michael Monreal 2008-04-28 02:48:18 EDT
Created attachment 303944 [details]
xorg.conf

I have to add NoAutoAddDevice to xorg.conf in order to set my own mouse
section. This works as shown here when using the "mouse" driver, but I get the
problem as described above when switching to "vmmouse".
Comment 2 Michael Monreal 2008-04-28 02:50:37 EDT
Created attachment 303945 [details]
xorg log

This is the bottom part of the xorg log. Interestingly, the vmmouse module is
loaded, but the evdev driver is loaded after it as well and it sets some
strange macintosh mouse options...
Comment 3 Michael Monreal 2008-04-28 02:55:01 EDT
Heh... I renamed the evdev input driver .so file to .so-bak, and now vmmouse
works fine. Shouldn't NoAutoAddDevice prevent the default driver from being used?
Comment 4 Bug Zapper 2008-05-14 06:17:31 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Peter Hutterer 2008-09-10 10:55:25 EDT
(In reply to comment #3)
> Heh... I renamed the evdev input driver .so file to .so-bak, and now vmmouse
> works fine. Shouldn't NoAutoAddDevice prevent the default driver from being used?

NoAutoAddDevices (mind the plural)


(In reply to comment #2)
> Created an attachment (id=303945) [details]
> xorg log
> 
> This is the bottom part of the xorg log. Interestingly, the vmmouse module is
> loaded, but the evdev driver is loaded after it as well and it sets some
> strange macintosh mouse options...

For the future, please submit logs as text files and don't cut them. For example, the typo here would have been easily spotted in the first 30 lines of the log (if you know what you have to look for).

I'm closing this as a duplicate to 434807, as the basic problem is the same - vmmouse doesn't scale properly and there's a conflict with the evdev driver.
Once we fix the scaling issues (and others) this bug will be gone as well.

*** This bug has been marked as a duplicate of bug 434807 ***

Note You need to log in before you can comment on or make changes to this bug.