Bug 444412 - radeon X crash when closing other X server
radeon X crash when closing other X server
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-28 06:14 EDT by Alexander Boström
Modified: 2008-05-05 12:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-05 12:04:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel oops and misc messages (3.73 KB, text/plain)
2008-04-28 06:14 EDT, Alexander Boström
no flags Details

  None (edit)
Description Alexander Boström 2008-04-28 06:14:55 EDT
(Maybe kernel is the right component, rather?)

Description of problem:
When starting an extra X server (:1), the original server (:0) crashes when one
returns to it by closing :1. Also, switching virtual console to :0 while :1 is
running crashes both servers.

Version-Release number of selected component (if applicable):
kernel-2.6.25-8.fc9.x86_64
xorg-x11-drv-ati-6.8.0-10.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install F9 preview x86_64, update, reboot.
2. Log in.
3. Either use fast user switch or su and "startx -- :1"

Additional info:

Kernel oops:
BUG: unable to handle kernel NULL pointer dereference at 0000000000000000
IP: [<ffffffff882f463e>] :radeon:radeon_cp_init_ring_buffer+0x128/0x35d

Complete dmesg is attached.

Hardware:
Intel Core 2 Duo
ATI Technologies Inc RV516 [Radeon X1300/X1550 Series]
Comment 1 Alexander Boström 2008-04-28 06:14:55 EDT
Created attachment 303955 [details]
Kernel oops and misc messages
Comment 2 Matěj Cepl 2008-04-29 16:12:09 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Alexander Boström 2008-05-05 03:29:53 EDT
After updating to

kernel-2.6.25-14.fc9.x86_64
xorg-x11-drv-ati-6.8.0-12.fc9.x86_64

it seems I can't reproduce this anymore.
Comment 4 Matěj Cepl 2008-05-05 12:04:05 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.