Bug 444413 - Cannot use attach disk if subdriver option is wrong in blktap
Cannot use attach disk if subdriver option is wrong in blktap
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks: 391501 409971 449772
  Show dependency treegraph
 
Reported: 2008-04-28 06:19 EDT by Adam Stokes
Modified: 2010-10-22 20:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:12:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backport of upstream changeset to RHEL5 (1.27 KB, patch)
2008-07-10 08:06 EDT, Daniel Berrange
no flags Details | Diff
Backport of upstream changeset to RHEL5 v2 (1.28 KB, application/octet-stream)
2008-07-10 08:17 EDT, Daniel Berrange
no flags Details

  None (edit)
Description Adam Stokes 2008-04-28 06:19:33 EDT
Description of problem:
I do the following setting in the disk item of the definition file.

--- /etc/xen/guest_domain ---
name = "guest_domain"
...
disk = [ "phy:/dev/sda5,xvda,w", "tap:ZZZ:/root/file.img,hda,w" ]
vif = [ "mac=00:16:3e:5b:f1:0d,bridge=xenbr0,script=vif-bridge" ]
-----------------------------

Though a definition of disk is wrong,
I can start a domain by a "xm create (virsh start)" command
and disk of the wrong definition is connected on a guest domain.

Version-Release number of selected component (if applicable):
xen 3.0

How reproducible:
100%

Steps to Reproduce:
1. make a image file.
# dd if=/dev/zero of=/root/file.img count=1000 bs=5000000

2. add the following setting to the disk item of the definition file.
"tap:ZZZ:/root/file.img,hda,w"
    ^^^
3. start a guest domain with the definition file which increased a change with
step-2.
xm create /etc/xen/guest_domain
(virsh start guest_domain)

  
Actual Results:
Though a definition is wrong,
VM boots but cannot use tap:ZZZ disk.

Expected Result:
"xm create (virsh start)" output an error.

Additional info:
changeset 15815: 2f13d0f2b07c
 xend: Add blktap disk type check
 http:/ /xenbits.xensource.com/xen-unstable.hg/rev/2f13d0f2b07c
Comment 1 RHEL Product and Program Management 2008-06-02 16:03:38 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Daniel Berrange 2008-07-09 09:30:25 EDT
Since the patch is upstream, its easy enough to add this
Comment 4 Daniel Berrange 2008-07-10 08:06:52 EDT
Created attachment 311470 [details]
Backport of upstream changeset to RHEL5
Comment 5 Daniel Berrange 2008-07-10 08:17:13 EDT
Created attachment 311471 [details]
Backport of upstream changeset to RHEL5 v2
Comment 7 Daniel Berrange 2008-07-21 06:48:28 EDT
Built into xen-3.0.3-67.el5
Comment 10 errata-xmlrpc 2009-01-20 16:12:49 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0118.html

Note You need to log in before you can comment on or make changes to this bug.