Bug 444420 - [dmar] After upgrade kernel from 2.6.23.x to 2.6.24.x boot hangs
[dmar] After upgrade kernel from 2.6.23.x to 2.6.24.x boot hangs
Status: CLOSED DUPLICATE of bug 445553
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-28 06:43 EDT by lev
Modified: 2008-05-23 03:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-23 03:57:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lev 2008-04-28 06:43:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; cs-CZ; rv:1.8.1.14) Gecko/20080416 Fedora/2.0.0.14-1.fc8 Firefox/2.0.0.14

Description of problem:
Every version of 2.6.24 kernel crashes on same point with same report. I was try -noacpi without success.
Smolt report: http://www.smolts.org/show?uuid=pub_3ed14cfb-bb43-4b3c-a6ac-cd5c2703c637

Last seen screen on boot (rewriten by hand):

ACPI: bus type registered
pnp: PnP ACPI: found 17 devices
ACPI: ACPI bus type pnp unregistered
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
PCI: Using ACPI for IRQ routing
PCI: If a device doesn`t work, try "pci=routeirq". If it helps post a report
NetLabel: Initializing
NetLabel: domain hash size = 128
NetLabel: protocols = UNLABELED CIPSOv4
NetLabel: unlabeled traffic allowed by default
DMAR:Host address width 36
DMAR:DRHD (flags: 0x00000000)base: 0x00000000fed90000
DMAR:DRHD (flags: 0x00000001)base: 0x00000000fed93000
DMAR:RMRR base: 0x00000000defd0000 end: 0x00000000defd0fff
DMAR:RMRR base: 0x00000000defd1000 end: 0x00000000defd1fff
DMAR:RMRR base: 0x00000000defd2000 end: 0x00000000defd2fff
DMAR:RMRR base: 0x00000000defd3000 end: 0x00000000defd3fff
DMAR:RMRR base: 0x00000000defd4000 end: 0x00000000defd4fff
DMAR:RMRR base: 0x00000000defd5000 end: 0x00000000defd5fff
DMAR:RMRR base: 0x00000000defd6000 end: 0x00000000defd6fff
DMAR:RMRR base: 0x00000000defd7000 end: 0x00000000defd7fff
IOMMU: Setting identity map for device 0000:00:1a.2 [0xdefd7000 - 0xdefd8000]


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.upgrade kernel from F8 repository
2.reboot
3.hangs

Actual Results:


Expected Results:


Additional info:
Comment 1 Chuck Ebbert 2008-04-28 20:45:33 EDT
Adding this to the kernel boot options should work around the problem:

  intel_iommu=off

Also, a BIOS update may get the IOMMU working.
Comment 2 Chuck Ebbert 2008-05-23 03:57:06 EDT

*** This bug has been marked as a duplicate of 445553 ***

Note You need to log in before you can comment on or make changes to this bug.