Bug 444429 - Eric fails to run
Eric fails to run
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eric (Show other bugs)
7
noarch Linux
low Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-28 08:08 EDT by Kathryn Marks
Modified: 2009-01-30 20:38 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.9.5-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 16:55:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kathryn Marks 2008-04-28 08:08:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080325 Fedora/2.0.0.13-1.fc7 Firefox/2.0.0.13

Description of problem:
The program "eric" fails to run.  It appears to be loading but never completes.

Version-Release number of selected component (if applicable):
eric-3.9.5-2.fc7

How reproducible:
Always


Steps to Reproduce:
1.Install eric.noarch via yum
2.Start from either the GUI (Start - Development - Eric) or from a shell ($ eric3)


Actual Results:
Start from the GUI or a shell yields the same results.  "Eric" appears in the task bar with the rotating hourglass trying to load.  After approximately 10 seconds, the program loading in the task bar disappears.  The program never starts.

Expected Results:
The program should run.

Additional info:
[kathryn@Galaxy ~]$ eric3
/usr/bin/eric3: line 4: syntax error near unexpected token `('
/usr/bin/eric3: line 4: `PYTHONDOCDIR=/usr/share/doc/python-docs-2.5 (/html'


[kathryn@Galaxy bin]$ cat eric3
!/bin/sh

QT4DIR=/usr/lib/qt4
PYTHONDOCDIR=/usr/share/doc/python-docs-2.5 (/html
QTDOCDIR=/usr/share/doc/qt-devel-3.3.8/html
QT4DOCDIR=/usr/share/doc/qt4/html
export QT4DIR PYTHONDOCDIR QTDOCDIR QT4DOCDIR
exec "/usr/bin/python" "/usr/lib/python2.5/site-packages/eric3/eric3.py" $*


--- eric3       2008-04-28 20:28:13.000000000 +0900
+++ eric3~      2008-01-25 21:18:04.000000000 +0900
@@ -1,7 +1,7 @@
 #!/bin/sh

 QT4DIR=/usr/lib/qt4
-PYTHONDOCDIR=/usr/share/doc/python-docs-2.5/html
+PYTHONDOCDIR=/usr/share/doc/python-docs-2.5 (/html
 QTDOCDIR=/usr/share/doc/qt-devel-3.3.8/html
 QT4DOCDIR=/usr/share/doc/qt4/html
 export QT4DIR PYTHONDOCDIR QTDOCDIR QT4DOCDIR
Comment 1 Rex Dieter 2008-04-28 08:41:53 EDT
confirmed, looks like a typo.
Comment 2 Johan Cwiklinski 2008-04-28 08:46:25 EDT
Not exactly : I've used "print sys.version[:5]" to define python version, but on
F7, it returns 2.5 and not 2.5.x, that's the error.

I'll correct this and rebuild the package these evening, if no one has time
before :)
Comment 3 Rex Dieter 2008-04-28 08:50:34 EDT
Hrm... I'd feel a *lot* better of all those dirs were detected/generated at
runtime dynamically, instead of hard-coded at buildtime.
Comment 4 Johan Cwiklinski 2008-04-28 09:06:37 EDT
Indeed, but I really don't know how to achieve this.

If somebody have an idea...
Comment 5 Rex Dieter 2008-04-28 09:44:04 EDT
These are easy:
QT4DIR=`pkg-config --variable=prefix Qt`
QT4DOCDIR=`pkg-config --variable=docdir Qt`/html

Maybe this one is good/easy enough as-is:
PYTHONDOCDIR=/usr/share/doc/python-docs-2.5/html

qt(3) packaging doesn't have any easy way to extract this, so maybe leave as-is too:
QTDOCDIR=/usr/share/doc/qt-devel-3.3.8/html
Comment 6 Fedora Update System 2008-04-28 17:01:09 EDT
eric-3.9.5-3.fc7 has been submitted as an update for Fedora 7
Comment 7 Fedora Update System 2008-04-29 16:55:43 EDT
eric-3.9.5-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Herbert Carl Meyer 2009-01-30 19:45:41 EST
I am getting this error on eric-4.2.5-1.fc11 from rawhide on 2009.01.30. Has it regressed ? Was it fixed in 3.9.5-3 ? I will fix it by hand, edit /usr/bin/eric4
Comment 9 Rex Dieter 2009-01-30 20:33:13 EST
This is a *way* old report, please file a new bug for any new issues.
Comment 10 Rex Dieter 2009-01-30 20:38:36 EST
But the cause could very well be due to switch to python-2.6, very similar to the issue here.  I'll try to look when I have chance, but having another bug opened against the latest version is still preferable.

Note You need to log in before you can comment on or make changes to this bug.