This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 444432 - installing from iso images shared via NFS mount fails
installing from iso images shared via NFS mount fails
Status: CLOSED DUPLICATE of bug 443291
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-28 08:35 EDT by Jeff Layton
Modified: 2014-06-18 03:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 23:09:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2008-04-28 08:35:51 EDT
Using the Fedora 9 Preview release to boot from a netinst.iso image converted to
a USB key (machine is a Tablet PC and has no other removable media).

I select NFS as the install method and point the installer to a NFS server that
is exporting a directory with containing these files:

Fedora-9-Preview-i386-DVD.iso
SHA1SUM

...it allows me to partition and format the hard disk, but eventually fails with
a message that states:

"The installer has tried to mount image #1, but cannot find it on the hard drive.

Please copy the image to the drive and click Retry...."

Given that this is an NFS install, it doesn't seem like it ought to be trying to
copy the entire DVD.iso to the drive, so I'm not sure what it's asking. The
other VC's don't offer much info. VC5 has this:

    /bin/mount -n -t iso9660 -o defaults,ro /dev/loop2 /mnt/cdimage

...but there's no indication to what loop2 should be pointing. I've tried using
losetup to point loop2 at the iso image on the NFS mount, but it doesn't seem to
help.
Comment 1 Jeremy Katz 2008-04-28 23:09:53 EDT

*** This bug has been marked as a duplicate of 443291 ***

Note You need to log in before you can comment on or make changes to this bug.