Bug 444444 - xpvm handles cmd line parameter "-v" incorrectly
xpvm handles cmd line parameter "-v" incorrectly
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pvm (Show other bugs)
4.6
All Linux
medium Severity low
: rc
: ---
Assigned To: Doug Ledford
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-28 09:46 EDT by Milos Malik
Modified: 2008-12-23 13:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-19 13:18:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2008-04-28 09:46:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; cs-CZ; rv:1.8.1.14) Gecko/20080416 Fedora/2.0.0.14-1.fc8 Firefox/2.0.0.14

Description of problem:
The usage message of xpvm claims that command line parameter "-v" doesn't require any argument, but the reality is different...

$ xpvm -H
usage:  xpvm [ hostfile ] [ -PO ] [ -T trace ] [ -N name ]
         [ -M nbytes ] [ -HSetv ]

where:
------
hostfile   = Alternate XPVM Hostfile (~/.xpvm_hosts)
-P         = Start XPVM in PlayBack Mode
-O         = Start XPVM in OverWrite Mode (default)
-T trace   = Use "trace" as Default Trace File
-N name    = Use "name" as Local Network Hostname
-M nbytes  = Set Default Message Size to "nbytes"
-H         = Print This Help Information
-S         = Dump SDDF Trace File Headers (and exit)
-e         = Dump Raw PVM Event Text
-t         = Text Mode, No Animation in Views
-v         = Verbose Operation


Version-Release number of selected component (if applicable):
pvm-gui-3.4.5-10

How reproducible:
Always


Steps to Reproduce:
1. xpvm -v


Actual Results:
xpvm prints following message and exits:

Application initialization failed: "-v" option requires an additional argument
% 

Expected Results:
xpvm runs in verbose mode

Additional info:
Comment 1 Doug Ledford 2008-06-19 13:18:42 EDT
I'm closing this out as WONTFIX.  The xpvm program is a graphical tool and
doesn't really expect to be running in text mode by default, but in case you do
specify text mode, then the verbose flag is available.  So, even though the
message isn't real clear, the problem is that telling xpvm to be verbose (which
implies text console verbosity) *does* require an additional argument: text mode.

Note You need to log in before you can comment on or make changes to this bug.