Bug 444455 - python libxslt fails to load: "undefined symbol: xsltInitAllDocKeys"
python libxslt fails to load: "undefined symbol: xsltInitAllDocKeys"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libxslt (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-28 10:53 EDT by Bowe Strickland
Modified: 2008-04-28 12:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 12:06:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bowe Strickland 2008-04-28 10:53:41 EDT
fedora rawhide updated as of 28apr08....

[bowe@localhost ~]$ python
Python 2.5.1 (r251:54863, Apr  8 2008, 01:20:16) 
[GCC 4.3.0 20080404 (Red Hat 4.3.0-6)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import platform
>>> platform.dist()
('fedora', '9', 'Rawhide')
>>> platform.uname()
('Linux', 'localhost.localdomain', '2.6.25-0.121.rc5.git4.fc9', '#1 SMP Fri Mar
14 23:14:20 EDT 2008', 'i686', 'i686')
>>> import libxml2
>>> import libxslt
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.5/site-packages/libxslt.py", line 52, in <module>
    import libxsltmod
ImportError: /usr/lib/python2.5/site-packages/libxsltmod.so: undefined symbol:
xsltInitAllDocKeys
Comment 1 Daniel Veillard 2008-04-28 11:41:12 EDT
oh, crap ... the fix for 442097 broke libxslt-python because it removes
one of the public identifiers automatically added to the python bindings.
i'm rebuilding libxslt-1.1.23-3.fc10 with the augmented key patch which 
solves the problem on my machine,

  sorry for the inconvenience,

Daniel
Comment 2 Daniel Veillard 2008-04-28 11:42:38 EDT
*** Bug 444317 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Veillard 2008-04-28 12:06:19 EDT
585991 build (dist-f9, F-9:libxslt-1_1_23-3_fc9) completed successfully

585992 build (dist-f10, devel:libxslt-1_1_23-3_fc10) completed successfully

If libxslt-1_1_23-3_fc9 could be updated in F-9 compose tree that would be great.
If not I will push it to F-9 updates as soon as it opens,

Daniel

Note You need to log in before you can comment on or make changes to this bug.