Bug 444468 - KVM guest with virtio drivers fails to mount /boot in rc.sysinit
KVM guest with virtio drivers fails to mount /boot in rc.sysinit
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-28 11:21 EDT by Mark McLoughlin
Modified: 2008-04-28 15:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 15:03:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
serefpolicy-3.3.1-virtio-fixed-disk.patch (890 bytes, patch)
2008-04-28 11:21 EDT, Mark McLoughlin
no flags Details | Diff

  None (edit)
Description Mark McLoughlin 2008-04-28 11:21:28 EDT
A F-9 KVM guest using virtio drivers currently fails to mount /boot during
rc.sysinit with this:

avc:  denied  { read } for pid=1081 comm="mount" name="vda1" dev=tmpfs ino=261
scontext=system_u:system_r:mount_t:s0 tcontext=system_u:object_r:device_t:s0
tclass=blk_file
avc:  denied  { getattr } for pid=1081 comm="mount" path="/dev/vda1" dev=tmpfs
ino=261 scontext=system_u:system_r:mount_t:s0
tcontext=system_u:object_r:device_t:s0 tclass=blk_file

Turns out to simply be that we need to set the file contexts on /dev/vda*
correctly. Patch below.

Adding to F9Blocker because if mounting /boot fails and the user tries to update
the kernel, things are going to get mightily screwed up.
Comment 1 Mark McLoughlin 2008-04-28 11:21:28 EDT
Created attachment 303991 [details]
serefpolicy-3.3.1-virtio-fixed-disk.patch
Comment 2 Daniel Walsh 2008-04-28 15:03:16 EDT
Fixed in selinux-policy-3.3.1-43.fc9.noarch

Note You need to log in before you can comment on or make changes to this bug.