Bug 444477 - SWTError: No more handles
SWTError: No more handles
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-28 11:42 EDT by Jack Tanner
Modified: 2008-04-30 15:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 14:57:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Tanner 2008-04-28 11:42:37 EDT
Description of problem:

Eclipse segfaults for a new user (first run of Eclipse for this user). Running
on F8 with rawhide eclipse-jdt-3.3.2-9 and Sun JDK 1.6.0_04

workspace/.metadata/.log:

!SESSION 2008-04-28 10:33:08.274 -----------------------------------------------
eclipse.buildId=M20080221-1800
java.version=1.6.0_04
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.osgi 4 0 2008-04-28 10:33:09.925
!MESSAGE Application error
!STACK 1
org.eclipse.swt.SWTError: No more handles [gtk_init_check() failed]
        at org.eclipse.swt.SWT.error(SWT.java:3589)
        at org.eclipse.swt.widgets.Display.createDisplay(Display.java:836)
        at org.eclipse.swt.widgets.Display.create(Display.java:824)
        at org.eclipse.swt.graphics.Device.<init>(Device.java:152)
        at org.eclipse.swt.widgets.Display.<init>(Display.java:472)
        at org.eclipse.swt.widgets.Display.<init>(Display.java:463)
        at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:498)
        at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
        at
org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:133)
        at
org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:86)
        at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:169)
        at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:106)
        at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:76)
        at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:363)
        at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:508)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
        at org.eclipse.equinox.launcher.Main.main(Main.java:1148)

!ENTRY org.eclipse.osgi 2 0 2008-04-28 10:33:09.963
!MESSAGE One or more bundles are not resolved because the following root
constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-04-28 10:33:09.963
!MESSAGE Bundle
update@plugins/org.eclipse.linuxtools.changelog.cparser_2.6.1.jar was not resolved.
!SUBENTRY 2 org.eclipse.linuxtools.changelog.cparser 2 0 2008-04-28 10:33:09.963
!MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
!SUBENTRY 2 org.eclipse.linuxtools.changelog.cparser 2 0 2008-04-28 10:33:09.963
!MESSAGE Missing required bundle org.eclipse.cdt.ui_0.0.0.

!ENTRY org.eclipse.osgi 2 0 2008-04-28 10:33:09.964
!MESSAGE The following is a complete list of bundles which are not resolved, see
the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-04-28 10:33:09.964
!MESSAGE Bundle
update@plugins/org.eclipse.linuxtools.changelog.cparser_2.6.1.jar [177] was not
resolved.
!SUBENTRY 2 org.eclipse.linuxtools.changelog.cparser 2 0 2008-04-28 10:33:09.964
!MESSAGE Missing required bundle org.eclipse.cdt.core_0.0.0.
!SUBENTRY 2 org.eclipse.linuxtools.changelog.cparser 2 0 2008-04-28 10:33:09.964
!MESSAGE Missing required bundle org.eclipse.cdt.ui_0.0.0.
Comment 1 Andrew Overholt 2008-04-28 11:56:17 EDT
I have no idea what could cause this, but it looks like you have some issues
with installed packages.  What does the output of the commands listed here give?

http://fedoraproject.org/wiki/DebuggingEclipseProblems
Comment 2 Andrew Overholt 2008-04-28 15:19:22 EDT
Also, (and yes, this needs to go into the F9 release notes) if you had
previously run Fedora 8's Eclipse, you may need to run with -clean once.  That's
an upstream bug, BTW.
Comment 3 Jack Tanner 2008-04-29 18:57:33 EDT
$ for f in `rpm -aq | egrep "eclipse|swt"`; do rpm -qV $f; done
$ which java
/usr/bin/java
$ readlink -f `which java`
/opt/jdk1.6.0_04/jre/bin/java
$ which javac
/usr/bin/javac
$ readlink -f `which javac`
/opt/jdk1.6.0_04/bin/javac
$ java -version
java version "1.6.0_04"
Java(TM) SE Runtime Environment (build 1.6.0_04-b12)
Java HotSpot(TM) 64-Bit Server VM (build 10.0-b19, mixed mode)

Running with -clean produces a few more messages (below), and then crashes as above.
eclipse.buildId=M20080221-1800
java.version=1.6.0_04
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64 -clean

!ENTRY org.eclipse.update.configurator 2008-04-29 17:51:33.563
!MESSAGE Unable to find feature.xml in directory: /usr/share/eclipse/features/or
g.eclipse.pde.nls.ar_3.2.1.v200609270227

!ENTRY org.eclipse.update.configurator 2008-04-29 17:51:33.564
!MESSAGE Unable to find feature.xml in directory: /usr/share/eclipse/features/or
g.eclipse.jdt.nls.ar_3.2.1.v200609270227

!ENTRY org.eclipse.update.configurator 2008-04-29 17:51:33.564
!MESSAGE Unable to find feature.xml in directory: /usr/share/eclipse/features/or
g.eclipse.mylar_feature_2.0.0.v20070403-1300

!ENTRY org.eclipse.update.configurator 2008-04-29 17:51:33.564
!MESSAGE Unable to find feature.xml in directory: /usr/share/eclipse/features/or
g.eclipse.mylyn_feature_2.0.0.v20070627-1400

!ENTRY org.eclipse.update.configurator 2008-04-29 17:51:33.565
!MESSAGE Unable to find feature.xml in directory: /usr/share/eclipse/features/or
g.eclipse.platform.source.nls.ar_3.2.1.v200609270227

!ENTRY org.eclipse.update.configurator 2008-04-29 17:51:33.565
!MESSAGE Unable to find feature.xml in directory: /usr/share/eclipse/features/or
g.eclipse.rcp.nls.ar_3.2.1.v200609270227

!ENTRY org.eclipse.update.configurator 2008-04-29 17:51:33.566
!MESSAGE Unable to find feature.xml in directory: /usr/share/eclipse/features/or
g.eclipse.platform.nls.ar_3.2.1.v200609270227

!ENTRY org.eclipse.update.configurator 2008-04-29 17:51:33.566
!MESSAGE Unable to find feature.xml in directory: /usr/share/eclipse/features/or
g.eclipse.rcp.source.nls.ar_3.2.1.v200609270227

!ENTRY org.eclipse.update.configurator 2008-04-29 17:51:33.566
!MESSAGE Unable to find feature.xml in directory:
/usr/share/eclipse/features/org.eclipse.mylyn.context_feature_2.0.0.v20070627-1400

!ENTRY org.eclipse.update.configurator 2008-04-29 17:51:33.567
!MESSAGE Unable to find feature.xml in directory:
/usr/share/eclipse/features/org.eclipse.sdk.nls.ar_3.2.1.v200609270227

!ENTRY org.eclipse.update.configurator 2008-04-29 17:51:33.567
!MESSAGE Unable to find feature.xml in directory:
/usr/share/eclipse/features/org.eclipse.pde.source.nls.ar_3.2.1.v200609270227

!ENTRY org.eclipse.update.configurator 2008-04-29 17:51:33.568
!MESSAGE Unable to find feature.xml in directory:
/usr/share/eclipse/features/org.eclipse.jdt.source.nls.ar_3.2.1.v200609270227

Comment 4 Andrew Overholt 2008-04-30 09:51:55 EDT
Other than the old, borked NLS stuff (and apparently some weird mylar RPM
sticking around), I have no idea what's wrong here.
Comment 5 Jack Tanner 2008-04-30 14:57:03 EDT
The bug was in the wetware. (I was trying to run eclipse after an su to a test
account... which then could not run GUI apps on my $DISPLAY.) Sorry!
Comment 6 Andrew Overholt 2008-04-30 15:13:40 EDT
Don't worry about it.  Glad it's working for you :)

Note You need to log in before you can comment on or make changes to this bug.