Bug 444488 - firefox fails to run on ia64 F9-beta
firefox fails to run on ia64 F9-beta
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64 f9-ia64-blocker
  Show dependency treegraph
 
Reported: 2008-04-28 13:14 EDT by Doug Chapman
Modified: 2008-05-23 12:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-23 12:17:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2008-04-28 13:14:10 EDT
Description of problem:

I assume this is due to having mismatched versions of something in our build and
not an actual firefox bug.  Firefox was working a few weeks ago in our rawhide tree.

When starting firefox on ia64 it fails with:

Could not find compatible GRE between version 1.9b5pre and 1.9b5pre.

We would appreciate any suggestions as to what may be missing or mismatched here.


Version-Release number of selected component (if applicable):
firefox-3.0-0.55.beta5.fc9.ia64
xulrunner-1.9-0.55.beta5.fc9.ia64


How reproducible:
100%

Steps to Reproduce:
1. attempt to start firefox on ia64
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Prarit Bhargava 2008-04-29 06:31:44 EDT
From Yi Zhan on fedora-ia64-committee list,

"It's not a version mismatching, just we build the firefox and xulrunner
in a wrong order (we missing xulrunner 1.95b5 builds for quite a while
and then catch up). It could be easy resolved in the rawhide tree. 

For beta, a workaround is to manually changed the "Gecko" section
in /usr/lib/firefox-3.0b5/application.ini: 
form
	[Gecko]
	MinVersion=1.9b5pre
	MaxVersion=1.9b5pre
to
	[Gecko]
	MinVersion=1.9b5pre
	MaxVersion=1.9b5
I have tried this, firefox should work then. 

Since the issue should be fixed in today's rawhide, another workaround
is to encourage people to update firefox to the rawhide version before
using it."

Comment 2 Bug Zapper 2008-05-14 06:19:20 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.