This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 444532 - Cannot install via yum or pirut
Cannot install via yum or pirut
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-28 18:08 EDT by Keith
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 14:24:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Keith 2008-04-28 18:08:26 EDT
Description of problem:
pirut produces an exception when starting.  yum quits with error "NameError:
global name 'ParsingError' is not defined"

Version-Release number of selected component (if applicable):


How reproducible:
command with yum: yum install kmod-fglrx
OR try to run pirut.
 
Actual results:
(pirut gives same message as yum):

[root@localhost ~]# yum install kmod-fglrx
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 85, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 163, in getOptionsConfig
    disabled_plugins=opts.disableplugins)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 160, in _getConfig
    startupconf.pluginconfpath,disabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 306, in
doPluginSetup
    plugin_types, confpath, disabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 145, in __init__
    self._importplugins(types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 186, in
_importplugins
    self._loadplugin(modulefile, types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 195, in _loadplugin
    conf = self._getpluginconf(modname)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 277, in
_getpluginconf
    except ParsingError, e:
NameError: global name 'ParsingError' is not defined

Expected results:

New nvidia drivers should be installed

Additional info:
Comment 1 Keith 2008-04-28 18:13:35 EDT
This doesn't seem to be specific to the package I'm trying to install - pirut
crashes on startup (after root password).  The error is also produced with the
command:

[root@localhost ~]# yum list available

Comment 2 Seth Vidal 2008-04-28 22:09:52 EDT
what version of yum is this?
Comment 3 Keith 2008-04-29 02:46:45 EDT
It's 3.2.8

This is a fresh (24 hours ago) download of Fedora 8 64-bit, and it has performed
an online system update
Comment 4 Seth Vidal 2008-05-30 12:56:33 EDT
Well, we've fixed the traceback in later versions of yum in Fedora 9. Do you
have any plugins installed? B/c one of them appears to have a broken config file.
Comment 5 Kulbir Saini 2008-05-30 14:12:02 EDT
Close this bug :)
Comment 6 Keith 2008-05-30 16:46:55 EDT
Well, since finding this bug. I've done another fresh install of Fedora 8, but
am avoiding the online update thingy.  I can't remember now if there were any
plug-ins at the time.  I currently need it for work, and cannot invest much more
time experimenting, but when this project is over, I'll try an update and see
what happens - won't matter then if I trash it.  I'll do a bit of reading around
before I try Fedora 9 ...

Thanks for the feedback!

Note You need to log in before you can comment on or make changes to this bug.