Bug 444544 - [cpuidle] Frequent lockups
[cpuidle] Frequent lockups
Status: CLOSED DUPLICATE of bug 444059
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-28 19:20 EDT by Pat Gunn
Modified: 2008-05-02 18:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-02 18:59:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
partial dmesg output (3.46 KB, text/plain)
2008-04-28 19:20 EDT, Pat Gunn
no flags Details

  None (edit)
Description Pat Gunn 2008-04-28 19:20:48 EDT
Description of problem: System occasionally does a soft-lockup, most frequently
during terminal I/O but occasionally while idle (in screensaver). Network
interface remains up (pingable), and occasionally I can ssh in from other
systems and perform some activities but attempts to "su" always hang. Please
find attached the (partial) output of "dmesg" from one of those logins.
Here's the output of "uname -a":
Linux tremor.dachte.org 2.6.25-8.fc9.x86_64 #1 SMP Wed Apr 23 03:20:41 EDT 2008
x86_64 x86_64 x86_64 GNU/Linux
I am using the Fedora 9 prerelease.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Just using the system eventually causes the problem to manifest
Actual results:
Soft hang - gui becomes completely nonresponsive, attempts to switch to a VT
also fail. Network interface remains up, sometimes incoming ssh works.

Expected results:

Additional info:
Comment 1 Pat Gunn 2008-04-28 19:20:48 EDT
Created attachment 304055 [details]
partial dmesg output
Comment 2 Pat Gunn 2008-04-28 19:31:54 EDT
I should mention that this laptop has seen every version of Fedora from 5
onwards and I haven't had this problem before. 
Comment 3 Chuck Ebbert 2008-04-28 20:26:08 EDT
Try adding "processor.max_cstate=1" to the kernel boot options.
Comment 4 Pat Gunn 2008-04-29 14:40:30 EDT
Let's leave this open for a bit longer, but after adding that yesterday I
haven't yet had another lockup, which is encouraging. I'll add another comment
if it happens again.
Comment 5 Pat Gunn 2008-04-30 03:41:12 EDT
This appears to fix the problem. Should I make a note of it that I should always
add this to my system configurations with fedora from now on, or will this be
changed into a default?
Comment 6 Arjan van de Ven 2008-05-02 14:49:18 EDT
this will burn you a lot of power though; it basically disables a lot of power
saving that is going on...
Comment 7 Dave Jones 2008-05-02 14:58:03 EDT
This looks like a dupe of 444059
Comment 8 Pat Gunn 2008-05-02 15:33:28 EDT
I'm not sure if that's the case - my laptop is set never to suspend while
plugged in, and this problem happened primarily when my laptop was plugged in.
Comment 9 Dave Jones 2008-05-02 16:13:21 EDT
the suspend comment was a misnomer.  It later happened to me also after just
booting up and idling.   It looks like we both have the same ATI chipset,
(Turion64 cpu too maybe?)  and the backtrace is pretty much identical.
Comment 10 Pat Gunn 2008-05-02 18:32:03 EDT
As it so happens, we have the same cpu and chipset, according to lspci and

Unrelated: I wouldn't be surprised if we have to do the same tricks to make the
system basically usable (like disabling the trackpad due to i8042 wonkiness)....

So I guess this indeed a dupe.
Comment 11 Pat Gunn 2008-05-02 18:59:17 EDT

*** This bug has been marked as a duplicate of 444059 ***

Note You need to log in before you can comment on or make changes to this bug.