This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 444554 - wpa_supplicant does not start at boot (VERY ANNOYING BUG)
wpa_supplicant does not start at boot (VERY ANNOYING BUG)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-28 22:50 EDT by Răzvan Sandu
Modified: 2008-05-04 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-04 12:22:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
audit.log (2.07 MB, application/octet-stream)
2008-05-02 11:30 EDT, Răzvan Sandu
no flags Details

  None (edit)
Description Răzvan Sandu 2008-04-28 22:50:58 EDT
Description of problem:

wpa_supplicant does not start at boot, writting FAILED in red during system
initialization and throwing a message about a missing file (wpa_ctrl_open)

However, wpa_supplicant *does* start if it's restarted manually after system
initialization.

Version-Release number of selected component (if applicable):
wpa_supplicant-0.6.3-5.fc9.x86_64


How reproducible:
Always.

Steps to Reproduce:
1. Install fresh copy of Fedora 8 or later (unstable).
2. Perform all available online updates.
3. Mark wpa_supplicant in ntsysv to be started at boot.
3. Start the system and watch initialization.
  
Actual results:
wpa_supplicant does not start during boot

Expected results:
wpa_supplicant should start normally

Additional info:
Hardware is a Dell Inspiron 1520, please see smolt profile here:
http://www.smolts.org/client/show/pub_9d69eb22-c7a0-44ea-9e54-a49aa186b94c
Comment 1 Dan Williams 2008-05-01 06:42:55 EDT
Are you running with SELinux enabled at all?  What's the output of:

/usr/sbin/getenforce

Also, what's your wifi configuration?  WPA? WEP? Open?
Comment 2 Răzvan Sandu 2008-05-01 07:34:22 EDT
Hello,

/usr/sbin/getenforce
Enforcing

Wi-fi configuration is WPA2 with (an alphanumeric) preshared key/password.
IP address should be given by DHCP (a Fedora DHCP server put on the same
Ethernet segment as the WAP).

The WAP is a D-Link DWL-G700AP, B/G standard - works flawlessly after conection.

Regards,
Răzvan
Comment 3 Dan Williams 2008-05-01 10:14:52 EDT
After boot, what's the output of "ps aux | grep wpa_supplicant" ?  This may be
an SELinux issue, in that wlassistant doesn't have the right rules for SELinux.
Comment 4 Răzvan Sandu 2008-05-01 10:55:14 EDT
Here it is:



 4912 ?        Ss     0:00 wpa_supplicant -c /etc/wpa_supplic
/wpa_supplicant.conf -B -u -dddt -f /var/log/wpa_supplicant.log


Regards,
Răzvan
Comment 5 Dan Williams 2008-05-01 12:36:54 EDT
What's the contents of /var/log/audit/audit.log ?  You'll need to be root to
access that file.
Comment 6 Răzvan Sandu 2008-05-02 11:30:14 EDT
Created attachment 304394 [details]
audit.log

Here's the audit.log file, as requested.
Comment 7 Răzvan Sandu 2008-05-04 12:22:38 EDT
Seems to be corrected - now wpa_supplicant starts at boot.


wpa_supplicant-0.6.3-5.fc9.x86_64

Closing...


Note You need to log in before you can comment on or make changes to this bug.