Bug 444557 - The glxgears would hang up after running more than 30 minutes.
The glxgears would hang up after running more than 30 minutes.
Status: CLOSED DUPLICATE of bug 448653
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
4.5
All Linux
low Severity high
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-28 23:36 EDT by Orange.Ding
Modified: 2008-06-02 11:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 11:55:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orange.Ding 2008-04-28 23:36:09 EDT
Description of problem:
The glxgears would hang up after running more than 30 minutes.


Version-Release number of selected component (if applicable):
RHEL4.5 32bit
RHEL4.5 64bit
RHEL4.6 32bit
RHEL 5 32bit
RHEL 5 64bit
RHEL 5.1 32bit


How reproducible:


Steps to Reproduce:
1. Install the RHEL 4.5 32bit in Munich (Ultra 20 M2 )or Stuttgart(Ultra 40 M2).
2. Install the Chipset and VGA Card driver by Supplemental CD
3. Run the glxears.
4 Wait more than 30 minutes, the glxears's GUI would hang up but the frames 
still can be displayed normally.
  
Actual results:
The glxgears would hang up after running more than 30 minutes.


Expected results:
The glxgears will work normal until it stop by manual.


Additional info:
There is a float number “angle” in the glxgears source representing the angle 
for turning the gears. Each frame 2.0 is added to it. 
Adding 2.0 to a big enough floating-point variant is a noop due to limited 
precision. Thus the gears stop turning. 

Actually you see the gear stop turning, but from source code side, it works 
continually, yes, it still a bug of glxgears.
The gears picture frame what you see is “still” because “angle” (float 
number) can’t add 2.0 after it “overflows” or exceed the limit precision.
Comment 1 Matěj Cepl 2008-05-03 09:14:44 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Jeremy West 2008-06-02 11:55:55 EDT

*** This bug has been marked as a duplicate of 448653 ***

Note You need to log in before you can comment on or make changes to this bug.