Bug 444566 - Feature regression with gnumeric 1.8.2
Feature regression with gnumeric 1.8.2
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Huzaifa S. Sidhpurwala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-29 03:01 EDT by Pat Gunn
Modified: 2009-02-26 17:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-26 17:39:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spreadsheet which works in older versions of gnumeric (1.66 KB, application/octet-stream)
2008-04-29 03:01 EDT, Pat Gunn
no flags Details

  None (edit)
Description Pat Gunn 2008-04-29 03:01:52 EDT
Description of problem:Previous versions of gnumeric in fedora allowed summaries
over computed values, e.g. SUM(A1:A9/B1:B9) or SUM(IF(B1:B9,A1:A9/B1:B9)). The
version included in FC9 preview does not.


Version-Release number of selected component (if applicable): 1.8.2


How reproducible: 100%


Steps to Reproduce:
1.
2.
3.
  
Actual results:Evaluation fails


Expected results:


Additional info:See attached file
Comment 1 Pat Gunn 2008-04-29 03:01:52 EDT
Created attachment 304074 [details]
Spreadsheet which works in older versions of gnumeric
Comment 2 Huzaifa S. Sidhpurwala 2008-04-29 06:57:46 EDT
I can reproduce this.
Looks like this is no longer supported, you need to use SUM(A4:A6)/B4/B9 instead

I am going to probe a little more tomorrow.
Comment 3 Pat Gunn 2008-04-30 06:17:31 EDT
I would like to request then that Fedora9 consider inclusion 1.6 of gnumeric
then instead of 1.8. Breaking of people's existing spreadsheets is not a good
thing in an upgrade.
Comment 4 Pat Gunn 2008-04-30 08:04:43 EDT
Working with the developers, we found that forcing array evaluation
(control-shift-enter) on all cells that previously worked using standard
evaluation results in spreadsheets working again. They are considering adding an
internal flag for spreadsheets enabling old-style evaluation though.
Comment 5 Bug Zapper 2008-05-14 06:21:38 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 lexual 2009-02-26 07:58:29 EST
Pat, was is this resolved for you now?
Comment 7 Pat Gunn 2009-02-26 11:42:15 EST
It's upstream at http://bugzilla.gnome.org/show_bug.cgi?id=530711
I'll poke them.

Note You need to log in before you can comment on or make changes to this bug.