Bug 444588 - --exclude doesn't handle during `yum remove`
--exclude doesn't handle during `yum remove`
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-29 07:49 EDT by Petr Sklenar
Modified: 2008-04-29 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 10:37:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2008-04-29 07:49:28 EDT
Description of problem:
yum --exclude kernel remove kernel
Yum is trying to remove kernel but kernel should be excluded 

Version-Release number of selected component (if applicable):
yum-3.2.8-9.el5, all

How reproducible:
always

Steps to Reproduce:
1. yum --exlude kernel remove kernel 
#yum is trying remove kernel but it is in exclude part

  
Actual results:
remove package which is in --exclude <package>

Expected results:
not remove package in --exclude part, or write message that it isn't supported

Additional info:
yum --exclude kernel update kernel   --- works
yum --exclude kernel install kernel  --- works
yum --exclude kernel remove kernel  --- doesn't
Comment 1 Petr Sklenar 2008-04-29 07:53:01 EDT
 yum remove aide --exclude=aide
Loading "protect-packages" plugin
Loading "skip-broken" plugin
Loading "list-data" plugin
Loading "security" plugin
Loading "rhnplugin" plugin
Loading "aliases" plugin
Loading "kmod" plugin
Loading "basearchonly" plugin
Loading "downloadonly" plugin
Loading "changelog" plugin
Loading "protectbase" plugin
Loading "filter-data" plugin
Setting up Remove Process
rhel-i386-server-5        100% |=========================| 1.4 kB    00:00     
Excluding Packages in global exclude list
Finished
0 packages excluded due to repository protections
Resolving Dependencies
--> Running transaction check
---> Package aide.i386 0:0.12-7 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Removing:
 aide                    i386       0.12-7           installed         263 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       0 Package(s)         
Remove       1 Package(s)         

Is this ok [y/N]: 
Comment 2 James Antill 2008-04-29 10:37:49 EDT
 Yeh, there are other cases where are excludes are not optimal.

 However I doubt we'll ever process excludes on the rpmdb side, it just doesn't
make sense ... for instance what happens if you have pkg-X installed which
conflicts with pkg-Y ... doing yum --exclude=pkg-X install pkg-Y would be a
really bad idea to try and do (although rpm would stop us).

 Excludes really means "ignore this pkg from the repos."

 What do you want the above thing to do? What is the usecase?
Comment 3 Petr Sklenar 2008-04-29 11:37:25 EDT
If --exclude works with install or update  I meant that it could work with
remove and it didn't write any message. But OK, I know that there much important
thing to do.
bye

Note You need to log in before you can comment on or make changes to this bug.