Bug 444598 - pam_namespace cannot unmount instance because bonobo open fds
pam_namespace cannot unmount instance because bonobo open fds
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bonobo (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-29 10:04 EDT by Dominick Grift
Modified: 2008-05-02 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 12:45:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsof | grep testuser with commands (7.63 KB, application/octet-stream)
2008-04-29 10:29 EDT, Dominick Grift
no flags Details

  None (edit)
Description Dominick Grift 2008-04-29 10:04:23 EDT
Description of problem:
When using poly-instantiation with pam_namespace, pam cannot unmount the
instantiated space ( i think because some proces is still active )

upon inspection with lsof i noticed some entries related:

sh-3.2# /usr/sbin/lsof | grep testuser
gnome-key  7777  testuser  cwd   unknown                         /proc/7777/cwd
(readlink: Permission denied)
gnome-key  7777  testuser  rtd   unknown                         /proc/7777/root
(readlink: Permission denied)
gnome-key  7777  testuser  txt   unknown                         /proc/7777/exe
(readlink: Permission denied)
gnome-key  7777  testuser    0u  unknown                         /proc/7777/fd/0
(readlink: Permission denied)
gnome-key  7777  testuser    1u  unknown                         /proc/7777/fd/1
(readlink: Permission denied)
gnome-key  7777  testuser    2u  unknown                         /proc/7777/fd/2
(readlink: Permission denied)
gnome-key  7777  testuser    4u  unknown                         /proc/7777/fd/4
(readlink: Permission denied)
gnome-key  7777  testuser    5u  unknown                         /proc/7777/fd/5
(readlink: Permission denied)
gnome-key  7777  testuser    6u  unknown                         /proc/7777/fd/6
(readlink: Permission denied)
gnome-key  7777  testuser    7u  unknown                         /proc/7777/fd/7
(readlink: Permission denied)
gnome-key  7777  testuser    8u  unknown                         /proc/7777/fd/8
(readlink: Permission denied)
gnome-key  7777  testuser    9u  unknown                         /proc/7777/fd/9
(readlink: Permission denied)
gnome-key  7777  testuser   10u  unknown                        
/proc/7777/fd/10 (readlink: Permission denied)
gnome-key  7777  testuser   11u  unknown                        
/proc/7777/fd/11 (readlink: Permission denied)
gnome-key  7777  testuser   12u  unknown                        
/proc/7777/fd/12 (readlink: Permission denied)
gnome-key  7777  testuser   14u  unknown                        
/proc/7777/fd/14 (readlink: Permission denied)
gnome-key  7777  testuser   15u  unknown                        
/proc/7777/fd/15 (readlink: Permission denied)
gnome-key  7777  testuser   16u  unknown                        
/proc/7777/fd/16 (readlink: Permission denied)
gnome-key  7777  testuser   17u  unknown                        
/proc/7777/fd/17 (readlink: Permission denied)
gnome-key  7777  testuser   18u  unknown                        
/proc/7777/fd/18 (readlink: Permission denied)
gnome-key  7777  testuser   19u  unknown                        
/proc/7777/fd/19 (readlink: Permission denied)
bonobo-ac  8941  testuser  cwd   unknown                         /proc/8941/cwd
(readlink: Permission denied)
bonobo-ac  8941  testuser  rtd   unknown                         /proc/8941/root
(readlink: Permission denied)
bonobo-ac  8941  testuser  txt   unknown                         /proc/8941/exe
(readlink: Permission denied)
bonobo-ac  8941  testuser    0u  unknown                         /proc/8941/fd/0
(readlink: Permission denied)
bonobo-ac  8941  testuser    1u  unknown                         /proc/8941/fd/1
(readlink: Permission denied)
bonobo-ac  8941  testuser    2u  unknown                         /proc/8941/fd/2
(readlink: Permission denied)
bonobo-ac  8941  testuser    4u  unknown                         /proc/8941/fd/4
(readlink: Permission denied)
bonobo-ac  8941  testuser    5u  unknown                         /proc/8941/fd/5
(readlink: Permission denied)
bonobo-ac  8941  testuser    6u  unknown                         /proc/8941/fd/6
(readlink: Permission denied)
bonobo-ac  8941  testuser    7u  unknown                         /proc/8941/fd/7
(readlink: Permission denied)
bonobo-ac  8941  testuser    8u  unknown                         /proc/8941/fd/8
(readlink: Permission denied)
bonobo-ac  8941  testuser    9u  unknown                         /proc/8941/fd/9
(readlink: Permission denied)
bonobo-ac  8941  testuser   10u  unknown                        
/proc/8941/fd/10 (readlink: Permission denied)
bonobo-ac  8941  testuser   11u  unknown                        
/proc/8941/fd/11 (readlink: Permission denied)
bonobo-ac  8941  testuser   12u  unknown                        
/proc/8941/fd/12 (readlink: Permission denied)
bonobo-ac  8941  testuser   13u  unknown                        
/proc/8941/fd/13 (readlink: Permission denied)
bonobo-ac  8941  testuser   14u  unknown                        
/proc/8941/fd/14 (readlink: Permission denied)

this user (testuser) should be logged off

Version-Release number of selected component (if applicable):


How reproducible:
create a user and set it up to use poly-instantiation.
logon as that user
log off as that user
notices in var/log/secure how pam cannot unmount the instance in /tmp.
use lsof | grep testuser to see what is holding pam from unmounting the instance.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
pam cannot unmount the user instance

Expected results:
pam can unmount he user instance 

Additional info:
Comment 1 Dominick Grift 2008-04-29 10:29:54 EDT
Created attachment 304122 [details]
lsof | grep testuser with commands

this has the commands to
Comment 2 Ray Strode [halfline] 2008-04-29 14:49:46 EDT
mind trying the packages at 

 http://koji.fedoraproject.org/koji/taskinfo?taskID=588977

?
Comment 3 Dominick Grift 2008-04-30 03:53:12 EDT
I do not mind trying the (x86_64)packages but i can only find the source. I
seems that compilation failed? Should i get the src.rpm and rebuild?
Comment 4 Ray Strode [halfline] 2008-04-30 09:55:14 EDT
ah sorry, the task did fail and I forgot to update this report with the updated
build url.

http://koji.fedoraproject.org/koji/buildinfo?buildID=47604
Comment 5 Dominick Grift 2008-04-30 10:36:31 EDT
Thanks. I have installed the packages and although /var/log/secure still reports
that pam_namespace cannot unmount instance on /tmp:

Apr 30 16:28:40 localhost gdm-session-worker[5884]: pam_unix(gdm:session):
session opened for user testuser by (uid=0)
Apr 30 16:29:08 localhost gdm-session-worker[5884]: pam_namespace(gdm:session):
Unmount of /tmp failed, Device or resource busy
Apr 30 16:29:08 localhost gdm-session-worker[5884]: pam_unix(gdm:session):
session closed for user testuser

There no longer are any entries found when i try /usr/sbin/lsof | grep testuser

And so now i think it fails due to some other reason, which i havent figured out
yet. I think the bonobo issue is solved.
Comment 6 Matthias Clasen 2008-05-02 12:45:15 EDT
Closing this bug then. Please file another one if you find new issues.

Note You need to log in before you can comment on or make changes to this bug.