Bug 444609 - compiz fails to build for kde
compiz fails to build for kde
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: compiz (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Owen Taylor
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks: RHEL5u2_relnotes RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-04-29 11:03 EDT by Cameron Meadors
Modified: 2010-06-22 16:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
(all architectures) Running rpmbuild on the compiz source RPM will fail if any KDE or qt development packages (for example, qt-devel) are installed. This is caused by a bug in the compiz configuration script. To work around this, remove any KDE or qt development packages before attempting to build the compiz package from its source RPM.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-22 16:22:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cameron Meadors 2008-04-29 11:03:54 EDT
It appears that I have enought kde/qt devel packages to make the configure
script think it can build for kde, but I don't have all the necessary ones.



(cd .libs && rm -f libcompiz.la && ln -s ../libcompiz.la libcompiz.la)
make[3]: Leaving directory
`/usr/src/redhat/BUILD/compiz-3173a142efe5e7af83ebb534a074d9d2a0c67a86/gnome'
make[2]: Leaving directory
`/usr/src/redhat/BUILD/compiz-3173a142efe5e7af83ebb534a074d9d2a0c67a86/gnome'
Making all in kde
make[2]: Entering directory
`/usr/src/redhat/BUILD/compiz-3173a142efe5e7af83ebb534a074d9d2a0c67a86/kde'
Making all in window-decorator
make[3]: Entering directory
`/usr/src/redhat/BUILD/compiz-3173a142efe5e7af83ebb534a074d9d2a0c67a86/kde/window-decorator'
make[3]: *** No rule to make target `qdecorator.moc', needed by `all'.  Stop.
make[3]: Leaving directory
`/usr/src/redhat/BUILD/compiz-3173a142efe5e7af83ebb534a074d9d2a0c67a86/kde/window-decorator'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
`/usr/src/redhat/BUILD/compiz-3173a142efe5e7af83ebb534a074d9d2a0c67a86/kde'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
`/usr/src/redhat/BUILD/compiz-3173a142efe5e7af83ebb534a074d9d2a0c67a86'
make: *** [all] Error 2
Comment 1 Cameron Meadors 2008-04-29 11:05:54 EDT
If you have no kde/qt devel packages installed, compiz builds fine.  This should
be added to the release-notes for RHEL 5.2
Comment 2 Don Domingo 2008-04-29 20:11:43 EDT
just to clarify, Cameron: when you say "build compiz", do you mean build the
compiz rpm package from its srpm?
Comment 3 Cameron Meadors 2008-04-30 08:54:54 EDT
Yes.  The rpm fails to build if the configure script detects certain qt/kde
devel packages, but other necessary packages are missing.  The configure script
does not do a complete job detecting all necessary packages.
Comment 4 Don Domingo 2008-04-30 21:08:46 EDT
proposed release note:

<quote>
Running rpmbuild on the compiz source RPM will fail if any KDE or qt development
packages (for example, qt-devel) are installed. This is caused by a bug in the
compiz configuration script.

To work around this, remove any KDE or qt development packages before attempting
to build the compiz package from its source RPM.
</quote>

please verify if ok so i can add it up to the RHEl5.2 release notes. thanks!
Comment 5 Cameron Meadors 2008-05-01 08:45:38 EDT
Sounds good to me.
Comment 6 Don Domingo 2008-05-01 18:26:11 EDT
thanks Cameron. added to RHEL5.2 release notes updates.
Comment 9 Ryan Lerch 2008-08-10 21:56:16 EDT
Tracking this bug for the Red Hat Enterprise Linux 5.3 Release Notes. 

This Release Note is currently located in the Known Issues section.
Comment 10 Ryan Lerch 2008-08-10 21:56:16 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.
Comment 12 RHEL Product and Program Management 2009-03-26 12:50:21 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 14 Owen Taylor 2010-06-22 16:22:36 EDT
KDE support has been removed from the Compiz package for RHEL 6 making this irrelevant on continuing basis.

There are no plans to update RHEL 5 for this issue.

Note You need to log in before you can comment on or make changes to this bug.