Bug 444612 - packagekit prevents me from suspending
packagekit prevents me from suspending
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker F9PKBlocker
  Show dependency treegraph
 
Reported: 2008-04-29 11:07 EDT by Jesse Keating
Modified: 2013-01-09 22:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 12:04:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-04-29 11:07:06 EDT
Pretty frequently when I'm trying to suspend, package kit will be in the middle
of some refresh or another, and an attempt to suspend will wind up failing with
the loud beeping.  Of course, there doesn't seem to be any log output of why the
suspend fails, I just eventually narrowed it down to PackageKit by killing the
daemon and being able to suspend.

Can we please fix this for 9, this will hit a lot of people and cause a lot of
anger.
Comment 1 Richard Hughes 2008-04-30 04:50:41 EDT
When it does not allow you to reboot - what is the output of the pkmon command?
I can't reproduce. Thanks.

[root@hughsie-work etc]# /usr/share/PackageKit/helpers/yum/refresh-cache.py true
allow-cancel	true
percentage	0
status	refresh-cache
status	download-repository
subpercentage	0
percentage	23
percentage	46
percentage	69
percentage	92
percentage	95
subpercentage	100
status	download-group
subpercentage	0
subpercentage	21
subpercentage	37
subpercentage	66
subpercentage	69
percentage	100
[root@hughsie-work etc]# /usr/share/PackageKit/helpers/yum/get-updates.py none
allow-cancel	true
no-percentage-updates
status	info
Comment 2 Jesse Keating 2008-04-30 21:28:39 EDT
$ pkmon
Tasks:
2;cbecdeec;data	get-updates:download-package 
^C
Comment 3 Richard Hughes 2008-05-01 17:55:25 EDT
I can reproduce with master. I'll fix this tonight/tmw.

Richard.
Comment 4 Richard Hughes 2008-05-01 19:28:32 EDT
Can you re-test with http://koji.fedoraproject.org/koji/buildinfo?buildID=47839
please. Thanks.
Comment 5 Jesse Keating 2008-05-02 08:11:16 EDT
With that build I was able to successfully suspend while getting information
about updates.

Note You need to log in before you can comment on or make changes to this bug.