Bug 444630 - Firefox prints pages using text-align: justify with mashed up fonts
Firefox prints pages using text-align: justify with mashed up fonts
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-29 12:25 EDT by Andrew Schretter
Modified: 2008-04-29 19:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 19:47:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Postscript file from "Print to file" showing mashed up fonts (602.90 KB, application/postscript)
2008-04-29 12:25 EDT, Andrew Schretter
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 431427 None None None Never

  None (edit)
Description Andrew Schretter 2008-04-29 12:25:47 EDT
Description of problem:

Firefox prints pages using text-align: justify with mashed
up fonts.  Firefox renders the pages properly on screen, but
its postscript rendering for printing mashes up the fonts as
shown in the attached postscript file.

An example webpage demonstrating the problem is at :

http://registrar.duke.edu/bulletins/undergraduate/2007-08/ugbhtml/UGBHTML-04-1.html

A very similar problem occurs in seamonkey (as described in
my recently submitted bug 444627) but seamonkey actually renders
the on-screen page with mashed up fonts as well as the printed
rendering.  At least for the seamonkey issue, it is pango related
as compiling it without pango resolves the issue.  I haven't
recompiled firefox without pango to test the printing problem

Version-Release number of selected component (if applicable):

firefox-2.0.0.14-1.fc8

How reproducible:

Always

Steps to Reproduce:
1.Open firefox
2.Browse to
http://registrar.duke.edu/bulletins/undergraduate/2007-08/ugbhtml/UGBHTML-04-1.html
3.Print web page (to a file or printer)
  
Actual results:

Fonts are unreadable on printout where text-align: justify is used

Expected results:

Fonts should be readable 

Additional info:
Comment 1 Andrew Schretter 2008-04-29 12:25:47 EDT
Created attachment 304140 [details]
Postscript file from "Print to file" showing mashed up fonts
Comment 3 Matěj Cepl 2008-04-29 19:47:20 EDT
We found that this bug has been already registered in the upstream database
(https://bugzilla.mozilla.org/show_bug.cgi?id=431427) and believe that it is
more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.