Bug 444645 - System-config-printer depends on PackageKit
System-config-printer depends on PackageKit
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-29 14:44 EDT by Josh Lange
Modified: 2008-07-26 02:09 EDT (History)
0 users

See Also:
Fixed In Version: 0.7.82.3-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-17 18:27:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josh Lange 2008-04-29 14:44:09 EDT
Description of problem:
system-config-printer depends on PackageKit. This means that a user who doesn't
want to install packagekit, but does want system-config-printer must break the
package dependencies.


Steps to Reproduce:
[root@glinda ~]# rpm -e yum-packagekit PackageKit gnome-packagekit PackageKit-libs
error: Failed dependencies:
	/usr/bin/system-install-packages is needed by (installed)
system-config-printer-0.7.82.2-1.fc9.i386


Expected results:
There shouldn't be an issue. Why does system-config-printer rely on PackageKit?

Additional info:
PackageKit isn't a reasonable thing to keep around for any sizeable deployment,
removing it should be trivial.

If there is some advantage to having the gnome package widget, in terms of
printer management, there should be a runtime check for the feature, rather than
being a package dependency.
Comment 1 Rex Dieter 2008-04-29 15:57:08 EDT
> Why does system-config-printer rely on PackageKit?

afaik, because it uses it to install (possibly-missing) drivers.
Comment 2 Tim Waugh 2008-04-30 07:15:57 EDT
Run-time check added upstream.
Comment 3 Fedora Update System 2008-05-09 10:47:32 EDT
system-config-printer-0.7.82.3-1.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-05-13 11:21:47 EDT
system-config-printer-0.7.82.3-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-3820
Comment 5 Bug Zapper 2008-05-14 06:23:22 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Tim Waugh 2008-05-16 05:46:55 EDT
Works here.
Comment 7 Fedora Update System 2008-05-17 18:27:01 EDT
system-config-printer-0.7.82.3-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-07-26 02:09:37 EDT
system-config-printer-0.7.82.3-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.