Bug 444649 - Instalation fails due to rpm-4.3.3-22_nonptl.i386.rpm dependency on Rhel4U6
Instalation fails due to rpm-4.3.3-22_nonptl.i386.rpm dependency on Rhel4U6
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
422
All Linux
high Severity high
: ---
: ---
Assigned To: Jan Pazdziora
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-29 15:13 EDT by Preethi Thomas
Modified: 2008-05-03 08:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 03:44:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2008-04-29 15:13:24 EDT
Description of problem:

Instalation fails due to  rpm-4.3.3-22_nonptl.i386.rpm dependency on Rhel4U6

Version-Release number of selected component (if applicable):
 rhn-satellite-4.2.2-5-redhat-linux-as-i386-4-embedded-oracle.iso

How reproducible:
always

Steps to Reproduce:
1.mount & install
rhn-satellite-4.2.2-5-redhat-linux-as-i386-4-embedded-oracle.iso  on rhel4u6

2. installer fails

  
Actual results:

Installer fails as it requires rpm-4.3.3-22_nonptl.i386.rpm

Expected results:
 successful install

Additional info:
Comment 1 Jan Pazdziora 2008-04-29 15:42:27 EDT
Well, I wonder what the best way of handling the situation is, provided we do
not plan to release 4.2.3 ISO.

I suspect that the idea was that by now, customers are not really expected to
install new 4.2 Satellites, just upgrade the old ones (<= 4.2.2) to the latest
upgrade version (4.2.3).

So the customer should not hit this problem at all. For QA, you'll either do the
installation on RHEL 4.5, or install rpm-build and rpm-python from RHEL 4.6
prior to starting the Satellite 4.2.2 installation.

Do you agree with this and can we close this bugzilla as WONTFIX, or are some
other changes required?
Comment 2 Miroslav Suchý 2008-04-30 03:44:24 EDT
This is known bug, which is repeat every minor and maintance version of
satellite. It was properly fixed in 5.1, where we kicked our rpmbuild from
bootstrap. 
This will happen if you want to install *now* every old release. And since we
will not release ISO for this release and nobody should install 4.2.3 from ISO,
I'm saying we will not fix it.

If  you really want to do it, the workaround is to copy ISO to HDD and remove
rpmbuild from bootstrap and install it by up2date.
Comment 3 Brandon Perkins 2008-05-03 08:39:43 EDT
Agreed.  This is not something we'll fix for 4.2.3.

Note You need to log in before you can comment on or make changes to this bug.