Bug 444658 - RFE - Requested feature for satellite to store scripts that can be run on a client system
RFE - Requested feature for satellite to store scripts that can be run on a c...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.3
All Linux
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Tomas Lestach
Katello QA List
: FutureFeature, Triaged
: 428191 (view as bug list)
Depends On:
Blocks: sat-nextgen
  Show dependency treegraph
 
Reported: 2008-04-29 15:42 EDT by Issue Tracker
Modified: 2014-09-18 13:02 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-01 08:44:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2008-04-29 15:42:22 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2008-04-29 15:42:24 EDT
Customer likes the "remote scripts" feature of satellite, but would like to be able to store scripts within the interface.  
This event sent from IssueTracker by jwest  [SEG - Feature Request]
 issue 125654
Comment 2 Issue Tracker 2008-04-29 15:42:25 EDT
What is the exact nature of the problem trying to be solved with this
request?
* Customer has a set of scripts that he would like to be able to run via
the satellite

What, if any, business requirements are satisfied by this request? (What
is the use case context?)
* Customer would like to have the satellite be able to store scripts
similar to the current configuration management tools, but, be able to run
the scripts from the satellite on his clients.

List the functional requirement(s) for performing the action(s) that are
not presently possible. Please focus on describing the problem related
requirements without projecting any specific solution.
* The ability to store commands to be run from the satellite

Each functional requirement must have clear acceptance criteria so Red Hat
understands what success looks like. If test cases can be provided this
would be even more ideal (bonus points for RHTS test cases).
* Store a command or a script of commands to be run on a client

What is the desired release vehicle to satisfy these requirements? Major
release Minor release
* 5.2

Please justify with reference to the release vehicle policy described in
the RHEL Inclusion Criteria wiki page
* Should be an extension of rhn_check and the configuration channels

What package(s) are affected by this RFE? (List "new" if new technology
is likely to be required)
* rhns-server
  rhn-check


Issue escalated to SEG - Feature Request by: pconnell.
Internal Status set to 'Waiting on SEG'
Status set to: Waiting on Tech

This event sent from IssueTracker by jwest  [SEG - Feature Request]
 issue 125654
Comment 3 Jeremy West 2009-01-07 13:17:00 EST
*** Bug 428191 has been marked as a duplicate of this bug. ***
Comment 20 Bryan Kearney 2014-04-01 08:44:59 EDT
This feature request is being met by Red Hat Satellite 6 (GA later this year 2014) as follows: Satellite 6 will be delivering configuration management features via Puppet. The Puppet DSL can support scripts being run. These puppet modules will be stored in the Library and promoted with content.

Closing this as CURRENTRELEASE - please feel free to re-open if you feel that the above implementation does not fulfill the requirements, or open a new request for any additional, Satellite 6 specific improvements.

Note You need to log in before you can comment on or make changes to this bug.