Bug 444682 - setting picture_filename is ignored if show_desktop is set to false
setting picture_filename is ignored if show_desktop is set to false
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-29 19:18 EDT by Andrew McNabb
Modified: 2015-03-03 17:32 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.22.1-1.2008.03.26.8.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 07:07:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root window with compositing enabled (2.87 MB, image/png)
2008-05-05 16:34 EDT, Andrew McNabb
no flags Details

  None (edit)
Description Andrew McNabb 2008-04-29 19:18:15 EDT
I recently installed Fedora 9 Preview.  In the past (Fedora 7 and 8), I've been
setting the background image with gconftool-2.  It appears that something has
changed between Fedora 8 and Fedora 9 Preview.

The following doesn't work anymore:

/usr/bin/gconftool-2 --type string --set
/desktop/gnome/background/picture_filename /path/to/some/image.jpg

Note that I have the following set:

gconftool-2 --type bool --set /apps/nautilus/preferences/show_desktop false

Changing the picture_filename seems to work when show_desktop is true but is
ignored when show_desktop is false.

When show_desktop is set to false, the background image is properly loaded at
login time from the picture_filename setting.  However, any subsequent changes
are ignored, although the last set image will be used at the next login.

Thanks.
Comment 1 Andrew McNabb 2008-05-01 12:51:32 EDT
It looks like this might be related to the problem described by the editor lwn.net:

http://lwn.net/Articles/278492/

It looks like when show_desktop is set to false, nautilus isn't running at all
(which is probably the right thing).  However, it really seems strange that
nautilus would be required to set the background.  It definitely used to be
possible to change the background without nautilus.

Thanks.
Comment 2 Matthias Clasen 2008-05-05 01:38:13 EDT
Please try gnome-settings-daemon-2.22.1-1.2008.03.26.8.fc9

* Mon May  5 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-1.2008.03.26.8
- Fix background drawing without nautilus
Comment 3 Andrew McNabb 2008-05-05 11:31:44 EDT
Version gnome-settings-daemon-2.22.1-1.2008.03.26.8.fc9 isn't currently at
http://mirrors.kernel.org/fedora/development/ppc/os/Packages/.  I'll keep
looking for it, though.
Comment 4 Andrew McNabb 2008-05-05 12:10:09 EDT
Okay, I found it on Koji.  I've verified that 2.22.1-1 fixed the bug.

Thanks.
Comment 5 Andrew McNabb 2008-05-05 16:34:01 EDT
Created attachment 304556 [details]
root window with compositing enabled

So, 2.22.1-1 fixed the bug on my ppc box, but there's still a problem on my
x86_64 machine.  I'm attaching a screenshot.  Basically what's happening is
that the image is being changed in the root window, but the screen is not being
refreshed.  Just before the screenshot was taken, I updated the background
image several times while moving a window above.  The root window was redrawn
only where the moving window forced it to redraw.

Thanks.
Comment 6 Andrew McNabb 2008-05-06 15:41:23 EDT
Aha!  It's not about whether it's ppc or x86_64.  The difference was that the
one had /apps/metacity/general/compositing_manager set to true.  So, if
compositing is off, redrawing happens.  If compositing is on, the background
only redraws when forced to.
Comment 7 Matthias Clasen 2008-05-06 17:43:33 EDT
Thats an unrelated bug. Please file it against metacity.
Comment 8 Andrew McNabb 2008-05-07 12:57:15 EDT
Okay.  I just filed 445563.  Thanks.
Comment 9 Fedora Update System 2008-05-13 10:32:21 EDT
gnome-settings-daemon-2.22.1-1.2008.03.26.8.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-settings-daemon'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-3734
Comment 10 Bug Zapper 2008-05-14 06:24:20 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Fedora Update System 2008-05-21 07:07:25 EDT
gnome-settings-daemon-2.22.1-1.2008.03.26.8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.