Bug 444692 - system won't boot after install
Summary: system won't boot after install
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 9
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-30 03:56 UTC by Maxwell Bottiger
Modified: 2008-06-03 14:21 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 14:21:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Maxwell Bottiger 2008-04-30 03:56:24 UTC
Description of problem:
I created two software raid partitions on my scsi drives sdc and sdd.  /dev/md0
contains the boot partition, /dev/md1 contains the root LVM.  Both devices are
RAID 1, and the whole setup was created with the disk druid portion of anaconda.

After installation, the root partition cannot be found.  I have to install grub
on hd2 and hd3.  Then I need to modify /boot/grub/grub.conf because it points to
(hd1,0) instead of (hd2,0) or (hd3,0)

Version-Release number of selected component (if applicable):
Fedora 9 Preview, grub-0.97-33.fc9.x86_64

How reproducible:
Every time.  Correcting the bios drive order in the installer didn't help.

Steps to Reproduce:
1. Configure disks and reinstall
2.
3.
  
Actual results:
Either the grub console, or just the word "GRUB"

Needed to boot from the rescue CD to fix everything if the grub stage 1.5 didn't
load.

Expected results:
Splash screen

Additional info:
Anaconda should load grub onto the MBR of the drive containing /boot, or should
prompt with more advanced menus if the user selects custom partitioning scheme.
 This bug took a while to sort out.

Comment 1 Jeremy Katz 2008-05-01 01:51:13 UTC
If you do a custom partitioning scheme, then on the bootloader screen, there
already is the support for reordering the drives.  

Unfortunately, this is an area of x86 hardware that really sucks and we
generally can't figure it out automatically :(

Comment 2 Bug Zapper 2008-05-14 10:24:53 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.