Bug 444724 - iproute crash
iproute crash
Status: CLOSED DUPLICATE of bug 449933
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iproute (Show other bugs)
All Linux
low Severity low
: rc
: ---
Assigned To: Marcela Mašláňová
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2008-04-30 06:02 EDT by Jakub Hrozek
Modified: 2008-06-04 10:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-04 10:46:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jakub Hrozek 2008-04-30 06:02:52 EDT
Description of problem:
iproute does not check its parameters for correctness enough, see for 
# ip xfrm state update src dst proto esp enc 
replay-seq 1234

The parameters are incorrect, but despite that, iproute should not crash :)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. ip xfrm state update src dst proto esp enc 
replay-seq 1234
Actual results:

Expected results:
no crash
Comment 1 Marcela Mašláňová 2008-06-04 10:46:29 EDT

*** This bug has been marked as a duplicate of 449933 ***

Note You need to log in before you can comment on or make changes to this bug.